Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Referencing a previous question:

I would have expected System ▸ Administration ▸ Login Screen ▸ Play login sound to control this, but unchecking it does not prevent the drum beat sound from playing.

So, that question is still open, none of those answers actually work. It seems that, possibly, Firefox uses the same sound for JavaScript errors.

There's also:

thufir@tleilax:~$ 
thufir@tleilax:~$ nl /usr/share/gnome/autostart/libcanberra-login-sound.desktop
     1  [Desktop Entry]
     2  Type=Application
     3  Name=GNOME Login Sound
     4  Comment=Plays a sound whenever you log in
     5  Exec=/usr/bin/canberra-gtk-play --id="desktop-login" --description="GNOME Login"
     6  OnlyShowIn=GNOME;
     7  AutostartCondition=GNOME /desktop/gnome/sound/event_sounds
     8  X-GNOME-Autostart-Phase=Application
     9  X-GNOME-Provides=login-sound
thufir@tleilax:~$ 
thufir@tleilax:~$ nl /usr/share/gnome/shutdown/libcanberra-logout-sound.sh 
     1  #!/bin/sh

     2  #/usr/bin/canberra-gtk-play --id="desktop-logout" --description="GNOME Logout"
thufir@tleilax:~$ 
thufir@tleilax:~$ 

Now, I haven't rebooted, but even if that works, it won't fix the annoyance of the sound Firefox plays for some dialogs.

Where is this drum beat sound file?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

I believe that you refer to /usr/share/sounds/ubuntu/stereo/system-ready.ogg. Remove that file, and the drums shouldn't bother you again, at least, at the login screen.

As for Firefox, you could try disabling sound effects under Sound Preferences.

PS: You should have probably mentioned the version of Ubuntu you use.

share|improve this answer
    
That mostly did it. I already disabled sound effects, but clicked a redundant button and that did the trick. I think the annoyance, for me a least, is that the sounds are played at max volume. Just playing them in mplayer, they're fine. Oh, the login screen is fixed, I renamed that ogg as suggested. –  Thufir Feb 7 '12 at 8:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.