Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My current method is to mount the filesystem via SSH using Nautilus's graphical interface, but I would much prefer to be able to use some tool that mounts the AFS filesystem and gives me access to AFS-specific features (permissions, etc.). I've tried installing OpenAFS via apt-get, but so far the kernel module has refused to compile. Also, assuming I get OpenAFS installed, I'm not quite sure how to actually mount the remote filesystem to, say, /media/afs or some directory.

I'm running Maverick with the 2.6.36-020636-generic kernel from http://kernel.ubuntu.com/~kernel-ppa/mainline/

Thanks for the help!

share|improve this question
    
Have you tried installing using the Ubuntu-Kernel? It seems likely the module not compiling has to do with using the mainline Kernel. –  Stefano Palazzo Oct 29 '10 at 3:46
    
I was thinking that. I feel bad asking this, but what's the easiest way to revert? –  Ben Oct 29 '10 at 3:51
    
It should still be installed. When grub does it's thing on boot (for a few tenths of a second), press ESC to see the grub menu. Then select the older kernel version you want to boot. You can also just remove the mainline kernel for now. –  Stefano Palazzo Oct 29 '10 at 4:04
    
OK, that makes sense. I'll have to mess with it at some later date. I've been using the newer kernel because it lets me use vga_switcheroo, which is important because the driver for my discrete card doesn't work and sucks a lot of power, and the potential benefits of OpenAFS don't balance the power savings (and I currently lack time to play with both options extensively). Thanks, though! –  Ben Oct 29 '10 at 8:27
1  
For GRUB 2 you have to use Shift instead. –  JanC Oct 29 '10 at 9:19

3 Answers 3

up vote 2 down vote accepted

Update: In the end, it appeared that the problem was due to using the mainline kernel. Once the Ubuntu kernel was updated to include vga_switcheroo, I tried again and installing OpenAFS via apt-get worked just fine. Running sudo service openafs-client start starts OpenAFS and mounts the AFS directory at /afs, and I use klog username to authenticate via Kerberos.

share|improve this answer

Also, assuming I get OpenAFS installed, I'm not quite sure how to actually mount the remote filesystem to, say, /media/afs or some directory.

To specifically answer this part, this can be done by passing the -mountdir option to afsd, or modifying the /etc/openafs/cacheinfo file. To mount AFS on /media/afs instead of just /afs, pass -mountdir /media/afs to afsd, or specify the /media/afs directory in the first field inside /etc/openafs/cacheinfo. See afsd(8) and cacheinfo(5). AFS is traditionally always mounted on /afs, though; there's usually no reason to change it.

In order to pass the -mountdir option to afsd in Ubuntu, you need to modify /etc/openafs/afs.conf before the openafs client starts, and add the extra options to the OPTIONS or VERBOSE variables. It's probably easier to just modify cacheinfo instead.

share|improve this answer

Check this article: http://lug.rose-hulman.edu/wiki/HOWTO_Use_sshfs_to_mount_AFS/DFS_home

Hope this will help

share|improve this answer
    
Thanks! That's more or less what I was doing, except via Nautilus' built-in system. I didn't realise sshfs existed, though, which is good to know. –  Ben Nov 7 '10 at 4:19
    
Actually, they also have an article about doing AFS with OpenAFS, which was perfect! Thanks! –  Ben Nov 7 '10 at 4:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.