Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Kubuntu 11.10 (32-bit). I tried to install KDenLive in it. For installing KDenLive, I added the third party repository to get the latest version of the software . After installing its giving an error to upgrade MLT Module to version 0.7. Please tell me how to upgrade MLT Module. Is there any other video editing program that lets me cut a part of the video.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Could you tell how and from where did you try to install the Kdenlive ?

At here

From the Ubuntu repositories: http://packages.ubuntu.com/search?keywords=kdenlive&searchon=names&suite=oneiric&section=all

Package version is 0.8

Browsing to the Kdenlive home: http://www.kdenlive.org/

Binary section for Ubuntu: http://www.kdenlive.org/user-manual/downloading-and-installing-kdenlive/pre-compiled-packages/ubuntu-packages

They are recommending Sunab's PPA.

That is: https://launchpad.net/~sunab -> https://launchpad.net/~sunab/+archive/kdenlive-release

Adding the ppa:sunab/kdenlive-release:

sudo add-apt-repository ppa:sunab/kdenlive-release

.

[sudo] password for ...: 
You are about to add the following PPA to your system:
 kdenlive-release

 More info: https://launchpad.net/~sunab/+archive/kdenlive-release
Press [ENTER] to continue or ctrl-c to cancel adding it

Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /tmp/tmp.1Qn6lZTaZ6 --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver hkp://keyserver.ubuntu.com:80/ --recv 6976C1CEB06586061C2C0472B5115B98AA836CA8
gpg: requesting key AA836CA8 from hkp server keyserver.ubuntu.com
gpg: key AA836CA8: public key "Launchpad PPA for C.A.B/sunab" imported
gpg: Total number processed: 1
gpg:               imported: 1  (RSA: 1)

Updating the package database:

sudo apt-get update

Installing:

sudo apt-get install kdenlive

.

Reading package lists...
Building dependency tree...
Reading state information...
The following extra packages will be installed:
  dvdauthor dvgrab frei0r-plugins kdenlive-data libgavl1 libmlt++3 libmlt-data
  libmlt4 melt recordmydesktop xine-ui
The following NEW packages will be installed:
  dvdauthor dvgrab frei0r-plugins kdenlive kdenlive-data libgavl1 libmlt++3
  libmlt-data libmlt4 melt recordmydesktop xine-ui
0 upgraded, 12 newly installed, 0 to remove and 0 not upgraded.
Need to get 14.0 MB of archives.
After this operation, 68.4 MB of additional disk space will be used.
Do you want to continue [Y/n]?

Launching the Kdenlive...

enter image description here

Seems to work.

Edit - the libmlt++3/libmlt4/libmlt-data/melt version

The kdenlive, version: 0.8.2.1-0ubuntu0~sunab~oneiric1, is depending the libmlt++3/libmlt4/libmlt-data/melt, without any package version restrictions.

apt-cache show kdenlive

Package: kdenlive
Priority: optional
Section: video
Installed-Size: 4144
Maintainer: Olivier Banus <****>
Architecture: i386
Version: 0.8.2.1-0ubuntu0~sunab~oneiric1
...
Depends: ..., libmlt++3, libmlt4, ..., melt, libmlt-data, ...

If you have those installed then those won't be upgraded with the install kdenlive.

To fix this, run the upgrade:

sudo apt-get upgrade

or

sudo apt-get dist-upgrade

It should upgrade those packages to the latest version from the Sunab's PPA.

Other options

Is there any other video editing program that lets me cut a part of the video.

Yes there are many video editing programs. I'm using the Avidemux.

It is available from the Ubuntu repositories:

avidemux-qt: http://packages.ubuntu.com/oneiric-updates/avidemux-qt

Description: a free video editor - QT version

Avidemux is a free video editor designed for simple cutting, filtering and encoding tasks. It supports many file types, including AVI, DVD compatible MPEG files, MP4 and ASF, using a variety of codecs. Tasks can be automated using projects, job queue and powerful scripting capabilities. . This package contains the QT4 version.

There is also a GTK version - package: avidemux.

Few editors available from the Ubuntu repositories:

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.