Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is a problem that I have been experiencing for a while now (since 9.10); before that I used a beta driver from Creative (I have a SB X-Fi on my Dell XPS 710), and even though, I have to compile and link it every kernel update, it worked just fine.

Starting with Jaunty, Ubuntu detected my sound card, but the output on the speakers was very poor, it was very noisy with crackling sounds; I ended up switching Pulse Audio with ALSA, and then I got a clean sound output.

Now that I have upgraded to Maverick, the issue persists, and I want to know how to have Pulse Audio disabled, and have ALSA or OSS instead.

share|improve this question
add comment

2 Answers

The problem is usually caused by bad latency and incorrectly set frequency settings in Pulse Audio. it's possible to fix but disabling pulse audio is probably something to look into too.

See this article about all your sound options: https://help.ubuntu.com/community/UbuntuStudioPreparation

share|improve this answer
add comment

Try a combination of the commands

sudo alsa unload

killall pulseaudio 

Play audio and see if the distortion continues

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.