Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Bumblebee 3.0 (also tried Ironhide) (I have a Dell XPS 15) however my FPS is 8 when flying above Stormwind looking down at the AH. On Windows this was 18 FPS while having the graphics even higher and in D3D.

Is there anything what I could try to improve performance? Due to the fact I'm using OpenGL many graphics features are not available which means basically that my FPS should be a lot higher.

I'm using Wine 1.4 RC1.

Thanks in advance.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Do not expect the same performance using Wine compared with Windows. Wine as you probably know is used to emulate all layers necessary to run Windows applications, it will never be the same as you have in a Windows system.

For increasing the FPS I would suggest running all your gaming sessions under Unity2D, that is important because you do not have the composite desktop taking part of your graphics card performance.

For World of Warcraft as you said changing from D3D to OpenGL helps in most cases bit in the end you will have to eventually lower the graphic details options to run the game.

Try a lower resolution, decrease the graphic details a bit and them some more until you are happy with the performance.

When I played World of Warcraft on my Ubuntu system I noticed 2 things always: lag and ping to server was much better and graphics quality always had to be much lower than the one I used in Windows.

share|improve this answer
    
Fair enough and currently I am already running Unity2D. If I can't get it better, I'll just reinstall Win7 back. Thanks for your input though. –  Devator Feb 5 '12 at 20:55
1  
I have added a bit more commenting on this, I am not sure but I would not expect a "do this" and things start miraculously improving answer. Its a shame I know, blame Blizzard for being lame to never provide a Linux client! –  Bruno Pereira Feb 5 '12 at 20:58
    
Well thanks, I've disabled compiz using metacity --replace but still no improvement in FPS. I guess I'll switch over to Windows.. and only for the games it is. –  Devator Feb 5 '12 at 21:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.