Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Ubuntu 10.10. Following an update, when I restart my system (automatic login is my preference), a dialog box appears with the text:

"Enter your password to unlock your login keyring"

What's wrong? Can anyone explain why this appears?

share|improve this question
2  
the reason for gnome-keyring is so that you have to enter your password only once, you have to do it at least once remember. Otherwise, a potential thieve would be able to access your bank account, for instance. I'm always happy to enter my password for exactly this reason. :-) –  Stefano Palazzo Oct 29 '10 at 2:44
    
It should be mentioned that there is a bug report for this: bugs.launchpad.net/ubuntu/+source/pam-keyring/+bug/137247. In the GNOME world, this behavior is considered a good thing, as it promotes security. In the real world, users expect that that "Auto login" means they don't have to enter a password when they log in. In an ideal world, the keyring would be secure and convenient -- ahh the paradox. ;) –  michaelms Mar 29 '11 at 19:46
    
@MichaelMS If you enter that as an answer, I'd vote it up. –  belacqua Mar 29 '11 at 21:12

4 Answers 4

You are using gnome-keyring (vault passwords for programs). Login to gdm unlocked base gnome-keyring, and if autologin base gnome-keyring to unlock accounts manually after autologin.

You can disable the use of gnome-keyring in programs that store passwords in it. Or change to another method of storing passwords in these programs (eg: base64 or plain)

share|improve this answer
1  
How to do it? Can you explain briefly –  Alan Oct 29 '10 at 1:37
    
do not use plain! –  RolandiXor Oct 29 '10 at 5:31
    
Please explain better.. –  ThePhysician Oct 29 '10 at 5:50
    
Roland Taylor, plain is bad, but if he prefers to make better use autologin - sometimes the only way out –  DsXack Oct 29 '10 at 8:29
    
Alan, For each program that uses gnome-keyring different ways of disabling it. But all ways similar: in the program settings turn off support for gnome-keyring. –  DsXack Oct 29 '10 at 8:37

This is happening because your login password and the password for gnome-keyring is not matching. You might have changed the password of your user account.

You can resolve this in two ways:

1). If you know your old password, Reset the password of gnome-keyring to current password of your user account.

2). Delete the existing keyring.

To do these open a terminal and type the command seahorse. A window will open where you can manage the gnome-keyring and other keys. Under the 'Passwords' tab right click on the 'Passwords:login'. A menu opens and you can find both options (Change password and delete).

You can also delete the application that causing the error from the keyring list

share|improve this answer
1  
Again, no. If autologin is enabled (and it is, read the question) gnome-keyring will ask you for your password even if it matches your login one. –  Javier Rivera Oct 29 '10 at 13:22

You can still use the gnome-keyring without having the annoying box popping up by setting your password for gnome-keyring to be the same as your login password.

See this answer for more information on how to do this.

share|improve this answer
2  
This doesn't work when autologin is on, as in this poster case. –  Javier Rivera Oct 29 '10 at 11:42

This happens if you defined to auto-login into Ubuntu (without your password) and the computer tries to login to a password protected wifi network.

Explanation:

Every time you request to remember an external password, like log into a site and click on "remember password" (youtube, gmail, yahoo, etc.) and request to save the password, the password is saved into a file.

In order not to allow anyone to see these password, the file is encrypted so only you can have access to it - using your ubuntu password.

The wifi password is also protected in such a way, thus when logging in, the computer tries to connect to the WiFi, but needs to know the password, which is stored in the passwords file. To unlock and read this password file, it requests the user to enter Ubuntu's passwrod.

Solutions:

  • Disable the password protection by going to the "passwords and encryption keys" and changing the password of "default" keyring to none (Just don't type anything in the new password)
  • Just type the password when you log-in.
  • Not a complete solution: Make the wifi available to all user: How can I stop being prompted to unlock the 'default' keyring on boot?. You will still get the message when you open other applications that needs access to passwords, like the browser.

You should not disable the password if you are wary that someone may steel your computer and copy your passwords - Not my case, so I chose to disable the password protection.

share|improve this answer
    
The only password I really care about is my google's and I have 2-step authentication enabled, so even if someone steels my password, he can't really use it. Another motivation to disable the keyring password protection. –  kilaka May 24 '11 at 6:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.