Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have created a wireless access point on my eeepc 701 running a fresh install of Ubuntu 10.04. The configuration: Ubuntu 11.04 laptop --WIFI--> (ath0)eeepc (eth0) --ethernet cable-->My ISP router-->Internet

I followed this guide accurately: https://help.ubuntu.com/community/Router (only difference, I set my wireless card running Madwifi drivers issueing

sudo wlanconfig ath0 destroy, sudo wlanconfig ath0 create wlandev wifi0 wlanmode ap ath0

which seemed to work as my ath0 is now in Master mode.

My other machine can now see the connection, but can't seem to connect to it. Looks like the connection attempt times out.

Why could it be? I have spent two or three days reading how-tos and man pages, but as informative as it has been I still can't get things to work.

Some info (I put it on pastebin so I would not flood the thread, please tell me if I need to include it here):

http://pastebin.com/8pXrRB4p

Any help would be very appreciated. Please let me know if I need to post further info. Thanks

share|improve this question

1 Answer 1

Did you do the dhcp stuff? Your 11.04 latop might be asking for an ip address but not getting on from your eeepc. Maybe set a static ip on the 11.04 laptop and see if that helps? Something like

address 192.168.0.2
network 192.168.0.0
netmask 255.255.255.0
broadcast 192.168.0.255
gateway 192.168.0.1
share|improve this answer
    
Thank you for your help, but setting a static IP on the 11.04 laptop did not change anything. I tried using the script posted here ubuntuforums.org/showthread.php?t=1488953 which did not help but at least it gives me an error I think I can work on: No subnet declaration for wlan0 (0.0.0.0). ** Ignoring requests on wlan0. If this is not what you want, please write a subnet declaration in your dhcpd.conf file for the network segment to which interface wlan0 is attached. –  MrPantucci Feb 5 '12 at 11:22
    
Was this error on the laptop or eeepc? If it was on the eeepc can you pastebin your /etc/dhcpd.conf . If it was on the laptop check that you set the subnet (netmask) to 255.255.255.0 –  cosmorogers Feb 5 '12 at 13:13
    
Thank you again for your reply. That error is on my eeepc. My /etc/dhcpd.conf is empty, I put the configuration info into /etc/dhcpd3/dhcpd.conf, following an online tutorial. Here it is: pastebin.com/b8wGsa44 Should I set up the /etc/dhcp.conf instead? Thanks –  MrPantucci Feb 5 '12 at 17:44
    
Have a look at help.ubuntu.com/10.04/serverguide/C/dhcp.html Looks like you need to edit /etc/default/dhcp3-server and tell it what interface to listen to (in your case ath0). Looking at the docs again it looks like /etc/dhcpd3/dhcpd.conf is the correct place now –  cosmorogers Feb 5 '12 at 22:28
    
I enabled ath0 in etc/default/dhcp3-server, with INTERFACES="ath0", but I get the same error, even after reboot. I have read the guide you linked but I can't find an answer to my problem. Any other ideas? Thank you! –  MrPantucci Feb 7 '12 at 0:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.