Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed gnome-shell - for who knows what reason - on Natty, from gnome3 launchpad PPA:

sudo add-apt-repository ppa:gnome3-team/gnome3
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install gnome-shell
sudo apt-get install gnome-session

After I realized I made mistake:

ppa-purge ppa:gnome3-team/gnome3
sudo apt-get update

and reverted system to previous state. Everything seems fine except one problem - vertical spacing on some gtk elements. I had screenshot taken week ago and made new one for comparison (left window is good and right is bad):

http://i.stack.imgur.com/hDVLh.png

Screenshot is from scite editor, but it's same in other editors, in Eclipse, in Nautilus side pane... Everything is condensed and in some cases (Firefox 10 dropdown addressbar history) bottom part of font is missing because of this issue.

Changing theme doesn't help, so it's not some gtkrc issue. If I use spartan non GTK+ theme there is not issue, in case it matters

Can I do something to solve this issue?


Update 1:

I launched Guest Session, and there were no issues, so problem is in my own profile.
I deleted ~/.compiz folder, but nothing changed after relogin

Following the link provided by Amith, I did:

gconftool --shutdown
killall -r -I -9 dconf
killall -r -I -9 gconf
mv gconf-backup .gconf
mv config-dconf .config/dconf
sudo reboot

Still nothing :(

What else could it be?


Update 2:

I managed to make Nautilus side pane as before, by hand crafting current theme's gtkrc file:

GtkTreeView::vertical_separator = 2

Now if someone could only provide tip how to set vertical separator for editors gtk widgets (whatever they are called). I could not find any reference

Also I found out that root user doesn't have this problem, as can be seen from this screen-shot:

http://i.stack.imgur.com/qcAob.png

In case someone gets other idea ;)

share|improve this question
    
If you look at the PPA description page you will see that Natty has not been supported since December 2011. You will increasingly get more and more problems if you continue using this PPA. –  fossfreedom Feb 5 '12 at 10:00

2 Answers 2

Try resetting the gnome settings

Open up a terminal and run

tar czvf gnome-backup.tar.gz .gnome .gnome2 .gconf .gconfd .metacity

And then run:

rm .gnome .gnome2 .gconf .gconfd .metacity

This will reverse the gnome settings

Incase something goes wrong, use this command to fix it

tar -zxvf gnome-backup.tar.gz

Source: http://askubuntu.com/a/100175/17722

share|improve this answer
2  
thanks, but unfortunately there was no change. .metacity folder was missing, but I doubt that's important –  vlad Feb 4 '12 at 13:23
up vote 2 down vote accepted

It wasn't gnome-shell problem. Same day I also tried to browse font pack with Font Manager by adding folder to Font Manager without knowing that these fonts would be installed. It was 1GB font pack provided by Google, with various quality which made this problem

After removing this font folder everything back to normal. What a nightmare!

share|improve this answer
    
You can accept your own answer so that this question will no longer be considered "unanswered." –  michaelms Feb 9 '12 at 23:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.