Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just tried to play Quake3 (QuakeLive) on a new laptop with an i3 core integrated gpu, running Ubuntu 10.10. Strangely, the performance was terrible. I'm running on intel driver, which seems to load correctly. I know it's not a high-end system, but I got used to Q3 being fairly playable on 3yo built-in i850GM with single core cpu, which was obviously much worse.

After switching to i3, I get barely 5fps, even if I use very low resolutions (640x480 and similar).

What could affect the performance that much? What should I look for? There doesn't seem to be anything obvious in the Xorg logs, or my xsessionerrors.

share|improve this question
    
I tried this both with disabled and enabled compiz. With disabled, it's a bit faster, but still practically unusable (looks like still < 10fps). –  viraptor Oct 28 '10 at 22:12
    
Tested also openarena. That runs at >60fps with no problems. –  viraptor Oct 28 '10 at 23:41

1 Answer 1

up vote 4 down vote accepted

And the answer seems to be:

\r_ignorefastpath 0

Now I get really smooth graphics all the time.

share|improve this answer
1  
Nice, thanks for sharing the solution. Speaking of that I have an Urban Terror question I need to make. –  NightwishFan Oct 29 '10 at 0:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.