Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Every 3 to 5 seconds I get the following output in kernel.log file. How do you fix this?

Oct 28 00:04:30 host kernel: [57192.331327] pciehp 0000:00:1c.4:pcie04: Link Training Error occurs 
Oct 28 00:04:30 host kernel: [57192.331331] pciehp 0000:00:1c.4:pcie04: Failed to check link status
share|improve this question

1 Answer 1

Sounds like your machine doesn't support PCI-E hotplugging.

Assuming you have an eeepc, read here, particularly Post 15:

Well, there are 3 different issues with the 1005PE model, which are related.

First, Win7 compatible bios, check if the eeepc-laptop module is loaded: lsmod | grep eee If not, you'll need this kernel parameter: acpi_osi=Linux

Second, to fix the brightness, another parameter: acpi_backlight=vendor

Finally, the actual bug, as described in acpi4asus git: http://git.iksaif.net/?p=acpi4asus.git;a=commit;h=ced69c59811f05b2f8378467cbb82ac6ed3c6a5a

To work around the problem, disable hotplugging with this parameter: eeepc_laptop.hotplug_disabled=1

Summarizing, add the needed parameters to your Grub, see below, and update: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor eeepc_laptop.hotplug_disabled=1"

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.