Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't find a way to remove weekday name from clock applet in gnome-shell, is it possible without editing the source?

share|improve this question

3 Answers 3

Two answers to your original question:

For Unity, choosing 'Ubuntu' at the login screen you can do it:

  1. Click on the time and select 'Time and date settings'
  2. Select the 'Clock' tab
  3. Un-check 'Weekday'

time settings

For Gnome 3, choosing 'Gnome' at the login screen you cannot do it:

The setting does not exist as the screenshot shows below.

gnome settings

Best bet may be a Gnome 3 extension, or a bug report.

share|improve this answer
    
It looks like you are talking about old Unity that was based on GNOME 2.x. But gnome-shell is GNOME 3.x (and Unity from 11.10 is based on it) and there is no such settings unfortunately. –  int_ua Feb 4 '12 at 11:57
    
You are partially correct, the Gnome 3 desktop does not have this setting. The current Unity desktop does still have this feature. I'll edit my answer to match your newly edited question. –  Tom Brossman Feb 4 '12 at 13:25
    
Bug report it is. Thanks a lot :) –  int_ua Feb 5 '12 at 3:38

If you're using GNOME 3.x then you can adjust clock setting using gnome-tweak-tool. However, you can take out the the date but not the day (i.e. Sat cannot be changed so far as I can tell)!

sudo apt-get install gnome-tweak-tool

You can also look in g-settings via a terminal:

gsettings list-keys org.gnome.shell.clock
gsettings set  org.gnome.shell.clock show-date false
gsettings set  org.gnome.shell.clock show-date true

which gives only two options: show-date or show-seconds! Or you can open up the configuration editor, then open "org" - "shell" and you will see calendar and clock which you can change manually.

share|improve this answer
    
I was just looking through the Gnome-shell calendar.js and don't see an easy fix! even if you play with the code you will have to manually change it everytime there is a GS update ! –  bmbaker Feb 4 '12 at 14:37
    
Just what I feared. So we need a bugreport and a patch.. Thanks a lot! :) I hope I will try to find/make one tomorrow, but if someone will do it faster, do share a link :) –  int_ua Feb 5 '12 at 3:33
    
Did you notice const CLOCK_FORMAT_KEY on line 18? Looks promising, but I'm writing from my phone, will check later. –  int_ua Feb 5 '12 at 3:59
    
hmmm i will also take a look :-) –  bmbaker Feb 5 '12 at 7:54
    
No, it's in the /usr/share/gnome-shell/js/ui/dateMenu.js _updateClockAndDate function. I will try to rewrite it. –  int_ua Feb 9 '12 at 20:41
up vote 1 down vote accepted

I case you've missed it in comments, here are two patches:

Hide weekday

https://bugzilla.gnome.org/show_bug.cgi?id=669778

Custom format

https://bugzilla.gnome.org/show_bug.cgi?id=669782

However, they need a verification on the latest version of GNOME since I'm no longer using it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.