Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using ubuntu 10.04 LTS desktop and I don't have any sound output from the built-in speakers in my Dell N5040

share|improve this question

1 Answer 1

You need to edit this file /etc/modprobe.d/alsa-base.conf and then add a line in its end.

Use the following commands in a terminal

sudo gedit /etc/modprobe.d/alsa-base.conf &

Now add the following line at its end:

options snd-hda-intel model=generic

Now reboot your computer. It should solve your problem. If the solution doesn’t work it is likely that the term model = generic may not work in all the cases as sometimes it depends on the model of your sound card.

Find your sound card by typing aplay -l | grep card in a terminal

You can try replacing the word generic by the following words depending upon your model of Dell laptop:

options snd-hda-intel model=ref

Refrence

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.