Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Ubuntu on my asus x58c the install when fine but after the screen went black, I thought it was becouse I installed 64bit (the laptop has 4GB ram) but then when I installed the 32bit version the same thing happened.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Probably not 100%. The system has a SIS graphics controller included and those are seriously lacking support.

Regarding the black screen I found this fix for Natty (might be worth while checking if it is applicable to 11.10 too) (copy/paste from link and untested):

sudo apt-get install git xorg-dev libdrm-dev libtool mesa-common-dev

After installing these packages, then type on your terminal:

git clone git://github.com/hellnest/xf86-video-sismedia-0.9.1.git 
cd xf86-video-sismedia-0.9.1
./configure –prefix=/usr –disable-static 
make 
sudo make install 

Then reboot your system.

Default resolution is 1280×800.

If your system has a 1366×768 resolution, you can edit your xorg.conf, by typing :

sudo gedit /etc/X11/xorg.conf

Copy this script:

Section "Device"
    Identifier     "Configured Video Device"
    Option         "UseTiming1366" "yes"
EndSection

Section "Monitor"
    Identifier     "Configured Monitor"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Monitor        "Configured Monitor"
    Device         "Configured Video Device"
EndSection

Save, and its resolution will be changed but you can’t get your 3d effect. So the 3d Unity cannot be activated, but if you still need the Unity, you can install 2D Unity by going here:

Then activate your 2D Unity

sudo unity-2d-launcher

Reboot your system.

share|improve this answer
    
Thank you Rinzwind, worked like a charm! –  Karam Feb 3 '12 at 16:23
    
@karam wow I did expect that to be honest :D –  Rinzwind Feb 3 '12 at 18:49
    
@Rinzwind Hmmm. I removed 32bit and installed the 64bit and now I forgot the pattern in which I wrote "git clone git://github.com/hellnest/xf86-video-sismedia-0.9.1.git cd xf86-video-sismedia-0.9.1 ./configure –prefix=/usr –disable-static make sudo make install" Can you tell me when to hit enter so to speak. Thanks! (does this work for the 64bit version too) –  user44878 Feb 3 '12 at 22:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.