Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running openvpn (client) on a home ubuntu server.

I currently create the connection with the command:

sudo openvpn /path/to/config/file

If I don't run it as root, I get an error that the TUN interface can't be created.

I found an old thread on the topic where someone suggested adding your user to netdev, but after doing that I still get the same error.

How urgent is it to solve this problem? Does it really matter if I init the openvpn connection as root or not? Is it a security hazard?

Thanks!

share|improve this question

closed as too localized by gertvdijk, jrg Dec 31 '12 at 1:57

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

By default OpenVPN runs as root because needs it to create TUN devices.

I dont know if there's any security hazard, but in their wiki, you can find a guide to start OPENVPN with other unprivileged user.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.