Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a XPS 14z with an intel+nvidia video card, the optimus technology being handled with bumblebee version 3. I know that the HDMI port, wired to the Nvidia card is not supposed to work. However, the mini display port, wired to the intel card, should work.

When I connect a vga cable on the minidisplay adaptor, no screen is recognised, nor with the graphical interface, nor with xrandr:

Screen 0: minimum 320 x 200, current 1366 x 768, maximum 8192 x 8192
LVDS1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 309mm x 174mm 1366x768 60.0*+ 40.0
1360x768 59.8 60.0
1024x768 60.0
800x600 60.3 56.2
640x480 59.9
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)

I know that a procedure compatible with bumblebee 2.4 exists here. But has it been adapted to bumblebee 3 ? I guess modifications of etc/bumblebee/xorg.conf.nvidia should do the job, but I'm afraid to try without knowing precisely what I do !

Thanks for your help,

Nathan

share|improve this question
    
If the Mini DisplayPort is wired to the Intel GPU, the card is supposed to work without needing to fiddle with Bumblebee. –  Lekensteyn Feb 2 '12 at 22:42
    
Thanks Lekensteyn.You might be right, but the fact is that bumblebee is here, and necessary. I don't think it's the origin of the problem, since it's supposed to deal only with the nvidia card and not the intel card. –  nathan Feb 3 '12 at 3:32
    
Do /var/log/kern.log, /var/log/Xorg.0.log or /var/log/Xorg.8.log print extra lines when connecting the monitor? If it turns out that your DP is wired to the nvidia card, try starting an application with optirun, e.g. optirun glxspheres. This powers on the nvidia card and runs a program on it. –  Lekensteyn Feb 3 '12 at 9:58
    
Yes indeed, the screen turns on when i launch a command preceded by optirun. Thus, it seems that unfortunately, the minidisplay is wired to the nvidia card. However, even if the screen seems to receive an input, it's not recognised nor with the gnome interface nor with the nvidia interface...Would you have any idea where this could come from ? –  nathan Feb 17 '12 at 22:35

1 Answer 1

I have made the external monitor running with 14z. I use mini display port with VGA adapter. In my opinion you cannot wake it with Intel card. I use bumblebee. In previous versions there were some EDID problems, so I have only managed 640x480. Today I have got higher resolutions as well. Trying to wake HDMI kills my system (it stops responding).

The main clues are:

  1. The monitor is named DFP-1

  2. There is a problem with common mouse for both screens.

  3. use 'Option "FlatPanelProperties" "Scaling = Native"' in Screen section.

Bumblebee starts second X server using display :8. Because of that run for example "DISPLAY=:8 optirun glxspheres" to test the monitor. It means that you may need separate window manager for the display and you may have to provide or share mouse and keyboard.

(1) Per default system tries to use DFP-0 and the picture shows nowhere. I guess it should be responsible for HDMI port, but I didn't manage to run it as mentioned.

(2) My solution for the "mouse problem" is to use "void mouse" on display ":8" and than connect to it using VNC. In that manner I get a small window on my main laptop screen showing what is on the monitor.

(3) Nvidia tries to force some high resolution like 1920x1200 on the monitor causing smaller ones to show "incorrect frequency" message. One solution is to run nvidia-settings go to "GPU 0 > DFP-1" section and unmark "Force Full GPU Scaling". It may be also necessary to set another frequency. The problem is if the monitor shows "incorrect frequency" message how to run nvidia-settings on it. The other solution is this 'Option "FlatPanelProperties" "Scaling = Native"' in Screen section.

I hope this short description will help you run external monitor. Some additional information. My system is Ubuntu 10.04.4 LTS. The /etc/bumblebee/xorg.conf.nvidia content is:

Section "DRI"
        Mode 0666
EndSection

Section "ServerLayout"
    Identifier "Layout0"
    Option "AutoAddDevices" "false"
    Screen    "Screen0"
    InputDevice "void-mouse"
    Option         "Xinerama" "0"
EndSection

Section "Module"
        Load  "dbe"
        Load  "extmod"
        Load  "glx"
        Load  "record"
        Load  "freetype"
        Load  "type1"
EndSection

Section "Files"
    ModulePath "/usr/lib/nvidia-current/xorg,/usr/lib/xorg/modules"
EndSection

Section "Device"
    Identifier "Device1"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BoardName      "GeForce GT 520M"
    BusID "01:00:0"
    Option "NoLogo" "true"
#    Option "UseEDID" "false"
    Option "UseEDID" "true"
    Option         "IgnoreEDID"
#    Option "ConnectedMonitor" "DFP"
    Option "ConnectedMonitor" "DFP-1"
EndSection

Section "Screen"
    Identifier    "Screen0"
    Device    "Device1"
    DefaultDepth    24
#    Monitor    "CRT"
    Monitor    "DFP-1"
    Option         "TwinView" "0"
    Option         "metamodes" "1024x768_70 +0+0; 1024x768 +0+0; 800x600 +0+0; 1024x768_85 +0+0"
    Option      "FlatPanelProperties" "Scaling = Native"
    SubSection "Display"
#        Virtual    1366 768
#        Virtual    1024 768
    Depth   24
#   Modes   "640x480"
#   Modes   "800x600"
#   Modes   "1024x768" "800x600"
        Modes      "1920x1200" "1920x1080" "1680x1050" "1600x1200" "1440x900" "1280x1024" "1366x768" "1360x768" "1280x800" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "Extensions"
        Option "Composite" "Enable"
EndSection

Section "Monitor"
    Identifier    "DFP-1"
    VendorName    "Unknown"
    ModelName     "Unknown"
#    HorizSync  28.0 - 73.0
    HorizSync   31.0 - 82.0
#    VertRefresh    43.0 - 72.0
    VertRefresh 48.0 - 85.0
    Option        "DPMS"
    Modeline       "1920x1200"  193.25  1920 2056 2256 2592  1200 1203 1209 1245 -hsync +vsync
    Modeline       "1920x1080"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
    Modeline       "1680x1050"  146.25  1680 1784 1960 2240  1050 1053 1059 1089 -hsync +vsync
    Modeline       "1600x1200"  161.00  1600 1712 1880 2160  1200 1203 1207 1245 -hsync +vsync
    Modeline       "1440x900"  106.50  1440 1528 1672 1904  900 903 909 934 -hsync +vsync
    Modeline       "1366x768"   85.25  1366 1440 1576 1784  768 771 781 798 -hsync +vsync
    Modeline       "1280x800"   83.50  1280 1352 1480 1680  800 803 809 831 -hsync +vsync
    Modeline       "1280x1024"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync

# Linia wygenerowana przez nvidia-settings
ModeLine       "1024x768" 94.500 1024 1072 1168 1376 768 769 772 808 +hsync +vsync

EndSection

Section "InputDevice"
  Identifier "void-mouse"
  Driver "void"
EndSection
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.