Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How to install LaTeX package called "standalone" properly so I can get update with Synaptic package manager?

I know I can manually download the file and install it.

share|improve this question

2 Answers 2

up vote 8 down vote accepted

I'm the author of standalone. It is newer than TeX Live 2009, which is the version installed by Ubuntu and Debian. The current TeX Live version is 2011. If you install the vanilla version directly you get a TeX packages manager called tlmgr which can be used to install and update packages as long as they are part of TeX Live. I heavily recommend you to do a manual install. You can find instructions on TeX.SX: How to install “vanilla” TeXLive on Debian or Ubuntu?

Then you can install standalone with the following command:

tlmgr install standalone

BTW, you can update the packages and tlmgr itself using:

tlmgr update --self --all

An alternative is to install only the package manually. This can be very easily done using the TDS ZIP file available under http://mirrors.ctan.org/install/macros/latex/contrib/standalone.tds.zip. Simply unzip it in your local TEXMF folder, usally ~/texmf. You might need to run texhash ~/texmf afterwards.

share|improve this answer
    
Too bad the Ubuntu packages for TeXlive don't get updated once they're out. –  krlmlr Feb 3 '12 at 20:58
    
@user946850: If they would update to the newest TeX Live version once a year it would still be something. TL 2009 is pretty outdated and we see related issues of Ubuntu user on tex.stackexchange.com because of this. A manual install however is not a problem, can easily be managed and updated. One problem is that there are some dependencies which require the Ubuntu packages to be installed. –  Martin Scharrer Feb 4 '12 at 9:56
1  
...which can be worked around by creating a dummy Debian package -- I've read about that. It's a mess. -- Do you know why it's the way it is? Why don't the Debian packages follow TeXlive? –  krlmlr Feb 4 '12 at 10:40
    
@user946850: AFAIK there is no dedicated maintainer for TeX Live under Debian and Ubuntu. The normal maintainers don't have the time to update it. I tried the dummy package, but this doesn't work to 100%. –  Martin Scharrer Feb 4 '12 at 15:02
1  
I actually had to unzip that package to /usr/share/texmf/tex/latex , not just /usr/share/texmf. –  David Doria Oct 31 '12 at 13:52

The search

apt-file search standalone.sty

doesn't give any results. This means that the package cannot be installed using Synaptic.

The reason is found in the answer by Martin Scharrer: The package is not included in TeXlive 2009 because it's too new. TeXLive 2009 is the version packaged with Ubuntu, there is no TeXlive 201. Also, the Ubuntu packages don't seem to receive updates once they're out.

The above is the reason why I installed TeXlive using tlmgr in my home, in ~/.texlive2011. Works like a charm.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.