Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My screen brightness changes on my MSI U120 when I log in. I can fix this by switching workspaces, and the screen will stay at a constant brightness. Changing the brightness using the function keys triggers the problem again. Occasionally if I change workspaces too late the touchpad will stop working. This happens on Joli OS too, but not on Windows. Interestingly, the flickering goes on at the logon screen in Ubuntu, at which point I press Control Alt Left / Right. But, the flickering does not happen at the logon screen in Joli OS, but after I login it starts.Any help would be greatly appreciated.

share|improve this question
    
No additional drivers are installed. I have Intel HD Graphics. –  William Feb 8 '12 at 13:45
    
Sorry, don't have access to the computer right now. I will report back later. –  William Feb 8 '12 at 13:51
add comment

2 Answers

I used to have a similar problem with MSI U100 but an upgrade... well, I believe from Karmic to Lucid fixed it. Or maybe I somehow fixed it and forgot how. I do not have that laptop anymore. Maybe the problem was re-introduced after that or maybe (less likely) your problem is a separate one.

If you search internet you'll find that there are numerous reports of people having this problem with U100 and U120 netbooks, with different Linux distributions.

Some reports suggest that upgrading BIOS fixes the problem. In case you decide to proceed you can get the new BIOS from the MSI website

share|improve this answer
    
I will try updating the BIOS on the netbook today and report back if that solves the problem. –  William Feb 8 '12 at 13:43
    
@William you should probably report back :P –  Thomas W. Feb 14 '12 at 16:07
    
I probably should :). I set the autologon option in Ubuntu to log me in automatically, bypassing the logon screen. For some reason that fixed the problem, the screen no longer flickers. Odd. But, thanks for everyone's suggestions. –  William Feb 14 '12 at 19:55
add comment
up vote 0 down vote accepted

I set the automatic logon option in the logon screen settings to on, thereby bypassing the logon screen entirely. For some odd reason that worked. The screen does not flicker and I can change the screen brightness through the function keys without any problems. Odd. Maybe this is a bug in GDM, lightdm or JDM, but I don't have enough information to file a bug report.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.