Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I keep having trouble getting the correct monitor resolution - every time I reinstall, I happen to use a newer Ubuntu release and the old tricks I used to know no longer work. Instead of leaving a long trail of questions for every new release, I am looking for a more universal and timeless solution.

What's the correct way to set the correct monitor resolution with an Nvidia GPU for a screen that does not send EDID values?

Note: This is a "dummy" question -- with the help from the chat, I already found the answer, and I am now going to add my own answer to document a solution that is hopefully universal.

share|improve this question
add comment

3 Answers 3

up vote 7 down vote accepted

Follow these steps.

Note that steps 6 and 7 are not usually necessary; try skipping them and if that does not work, repeat all steps and include these two. Some monitors don't send EDID information to the computer, so Ubuntu can't know what the monitor is capable of and only offers safe (low) resolutions. Those two steps resolve that problem.

  1. Reboot and restart in Recovery Mode.
  2. Type rm /etc/X11/xorg.xonf (Enter)
  3. Type reboot (Enter)
  4. Once you're at the normal Ubuntu desktop again, press Alt + F2 and type terminal (Enter)
  5. In the terminal, type sudo nvidia-xconfig (Enter). This will write a new xorg.conf file.
  6. Press Alt + F2 and type gksu gedit /etc/X11/xorg.conf (Enter).
  7. Look for the part beginning with Section "Monitor"and there enter the correct HorizSync and VertRefresh values. (See How do I look up the hsync/vsync values for my monitor?)
  8. Restart.
  9. Once you're at the normal Ubuntu desktop again, find "Nvidia X Server Settings" in the "start menu" and start that.
  10. In the section X Server Display Configuration, set the desired resolution and press the button Save to X Configuration File.
  11. Reboot.

You should now have the proper resolution!

Finally, copy the file /etc/X11/xorg.conf to a safe place in case you mess it up later and need to restore it.

share|improve this answer
    
Holy shit...I can't believe this worked. I've been trying to get higher resolutions to show all day. The primary fix for me was setting proper hsync and vsync values. After I did that, all the rest of the resolutions unlocked. THANK YOU! –  Nick Aug 29 '13 at 22:58
add comment

Using nVidia settings application

If your computer has the nvidia propietary drivers, you should have nvidia-settings installed and ready.

Command-line method

Run the following command:

nvidia-settings --query FlatpanelNativeResolution

If this returns nothing, or an error, try to look for valid attributes with:

nvidia-settings --query all | grep -i resolution

Then try the first command with one of the found attributes that sounds adequate.

GUI method

  1. Open nvidia-settings, either by looking for its launcher or running it as a command.
  2. In the section tree, go to your GPU.
  3. Now either browse all the items or look for an item which sounds like a device name, in my case I see DFP-0 (AUO).
  4. You will now see under Flatpanel Information a list of resolutions.
share|improve this answer
add comment

I got this issue fixed , I have a post on my blog :

http://gayanhewa.wordpress.com/2012/09/07/ubuntu-dual-monitors-with-nvidia-g96-series/

Let me know if it works for you, I simply added the correct refresh rates for my monitors in the xorg.conf , I have attached a sample.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.