Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was trying out Unity and then I uninstalled it but there is still an Ubuntu Netbook Edition option in the GDM session list. Accidentally clicking on that causes the user to log in to a broken desktop. How can I remove it from the list?

share|improve this question
add comment

3 Answers

up vote 9 down vote accepted

Go to the Ubuntu Software Center and use the search box in the upper right corner. Search for ubuntu-netbook and remove the packages ubuntu-netbook and ubuntu-netbook-default-settings.

share|improve this answer
    
To which I'll add be sure to check which session manager your login screen is using. I followed this advice and was greeted with a live but empty X display. It was only after seeing hhlp's answer that I noticed that GDM was still selecting Netbook session which - of course - couldn't run since it wasn't installed. Thanks to all three of you for helping me out of a white screen with cursor. –  msw Nov 3 '10 at 13:48
    
Correction: removing ubuntu-netbook-default-settings does the trick, but I'll leave my prior comment in case someone else only does the removal half-way and sees the same as I did. –  msw Nov 3 '10 at 13:52
add comment

The list is populated by looking at the contents of the /usr/share/xsessions directory. In here you’ll find files with the .desktop extension (extension hidden in some file managers, press CTRL+H). As these files are in a system folder, you will need root privileges to change or delete them.

share|improve this answer
add comment

After upgrading from Ubuntu 10.10 Lucid Lynx (10.10) Netbook Edition to Ubuntu 11.04 Natty Narwhal, the upgrade process does not remove the ubuntu-netbook and ubuntu-netbook-default-settings packages. Subsequent login attempts result in a broken desktop being displayed with background but no panels whatsoever.

In order to fix this problem, press CTRL+ALT+DEL and select the Restart option. When logging in after restart, after selecting a username, select Ubuntu session option from the drop-down box in the bottom bar. This will start the Natty's default session with Unity.

Next, run the following command in a Terminal window in order to remove the non-working option from the session list.

sudo apt-get remove ubuntu-netbook ubuntu-netbook-default-settings

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.