Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to add a DomU Operating system on Ubuntu 11.10.

I have successfully installed Xen.

Verified with

  • xm info
  • virsh-version

which returns this:

Compiled against library: libvir 0.9.2
Using library: libvir 0.9.2
Using API: Xen 3.0.1
Running hypervisor: Xen 4.1.

Now when I tried to install DomU it said:

unable to connect to 'localhost:8000':

, in VMM.

So, I followed this bug link.

I could now start adding DomU. When adding DomU, in last stage, it gives the following error:

Unable to complete install: 'POST operation failed: xend_post: error
from xen daemon: (xend.err "Error creating domain: device model
'/usr/lib/xen/bin/qemu-dm' not found")'

Traceback (most recent call last):   File
"/usr/share/virt-manager/virtManager/", line 44, in
    callback(asyncjob, *args, **kwargs)   File "/usr/share/virt-manager/virtManager/", line 1899, in do_install
   guest.start_install(False, meter=meter)   File "/usr/lib/pymodules/python2.7/virtinst/", line 1223, in start_install
    noboot)   File "/usr/lib/pymodules/python2.7/virtinst/", line 1291, in _create_guest
    dom = self.conn.createLinux(start_xml or final_xml, 0)   File "/usr/lib/python2.7/dist-packages/", line 1686, in
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self) libvirtError: POST operation failed: xend_post: error from
xen daemon: (xend.err "Error creating domain: device model
'/usr/lib/xen/bin/qemu-dm' not found")

I tried following this bug link that said, the bug is solved in the below package.

When I run ./configure in this, I am getting an error:

checking for LIBXML... no 
checking libxml2 xml2-config >= 2.6.0 ...
configure: error: Could not find libxml2 anywhere (see config.log for details).

What is the problem?

share|improve this question

migrated from Feb 2 '12 at 20:07

This question came from our site for professional and enthusiast programmers.

Main error was: (xend.err "Error creating domain: device model '/usr/lib/xen/bin/qemu-dm' not found")' I checked and found, my folder is /usr/lib/xen-4.1/~ Where will the "add-DomU" script called from? – sridutt Feb 2 '12 at 20:35

That solution you posted isn't very robust, now you have two directories worth of binaries to maintain, one that isn't even under package control. A simple symlink: ln -s /usr/lib/xen-4.1 /usr/lib/xen would have sufficed, same thing for qemu.

Also, Serge Hallyn answered your build question in the launchpad bug

sudo apt-get install libxml2-dev libxml2-utils

Alternatively, you could install the updated libvirt package directly by using apt pinning.

share|improve this answer
Thanks a ton, I am new to Linux and on a learning curve, so I had to do that. – sridutt Feb 7 '12 at 17:30
That's fine, please up vote and check mark the appropriate answers so we can close this issue out. Thanks. – ppetraki Feb 7 '12 at 18:38

I guess, I have solved it...

For the error

 (xend.err "Error creating domain: device model '/usr/lib/xen/bin/qemu-dm' not found")

Copy the directory in the following location

cp /usr/lib/xen-4.1/* -r /usr/lib/xen/

After this there was an error

libvirtError: <Fault: 3>

So, I had to

cp -r /usr/share/qemu-linaro/ /usr/share/qemu


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.