Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to automount partitions using mountmanager. But I don't know what I did. Pls help. I may find a way to automount but what I need is different

I need my sda6 and sda7 to mount at /media. (But I entered /mnt in mountmanager). Also some partitions are not showing in nautilus devices list.

My fdisk-l


Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders, total 312581808 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x2cf52cf4

Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *          63    51215219    25607578+   7  HPFS/NTFS/exFAT
/dev/sda2        51215281   312576704   130680712    f  W95 Ext'd (LBA)
/dev/sda5        51215283    71698094    10241406    7  HPFS/NTFS/exFAT
/dev/sda6        71698158   163862999    46082421    7  HPFS/NTFS/exFAT
/dev/sda7       163863063   267530444    51833691    7  HPFS/NTFS/exFAT
/dev/sda8       308496258   312576704     2040223+  82  Linux swap / Solaris
/dev/sda9       300111872   308494335     4191232   82  Linux swap / Solaris
/dev/sda10      267532288   291723263    12095488   83  Linux
/dev/sda11      291725312   300109823     4192256   82  Linux swap / Solaris

Partition table entries are not in disk order

Disk /dev/mapper/cryptswap1: 4292 MB, 4292870144 bytes
255 heads, 63 sectors/track, 521 cylinders, total 8384512 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x39ee04e1

Disk /dev/mapper/cryptswap1 doesn't contain a valid partition table

I want to reset my fstab or mount settings for sda6 and sda7 and I need my device lists back to normal. Pls help

I can't upload images here. My nautilus Devices list shows 26GB Filesystem 10GB Filesystem

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Just a random suggestion, perhaps uninstall mountmanager and use a different utility? You're familiar with commandline, so perhaps use fstab and 'sudo mount -a' would do the trick for you?

share|improve this answer
    
Yes. Thanks. I uninstalled mountmanager. Then I deleted the two entries - sda6 and sda7 from fstab. When restarted, nautilus devices list restored. And I used pysdm for automount. –  Vinod Feb 3 '12 at 3:54
    
pysdm has some issues - notably that when editing partition info in fstab, it adds a new line rather then editing the line already present. This can assist in causing some ridiculously confusing problems. Culling entries like you did is usually best. –  WindowsEscapist Oct 27 '12 at 19:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.