Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I want to be able to type in Hindi and want to set input method as ibus in gnome-language-selector window as shown on this blog

How ever each time when I select input method as ibus and close the window I log out and login again.Now check the ibus window preferences as in this snapshot

the options to Hindi which should come as shown in this snapshot is missing in my machine. I use Ubuntu 11.10 and I do not use Unity. I am using gnome which was installed using

   aptitude install gnome-session-fallback

The language support for Hindi is already enabled in gnome-language-selector window. What are my options?

share|improve this question

1 Answer 1

After a lot of Googling and continuous efforts to resolve this problem I finally found the solution a package ibus-m17n is also needed.Which installs the required databases for various kind of keyboard maps corresponding to the keys of that language.In above case by installing ibus only the daemon was running but one need to make sure that input langugage database is also installed. This database is usually in following folder


In my case for various input methods to be able to come in drop down menus of ibus preferences following files were needed


The above files are keymaps for Hindi langugage.Which are needed by the ibus daemon. Due to absence of above files I was not able to see any input method.A correctly configured ibus with local language database installed will look as follows

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.