Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed Ubuntu 11.10 several months ago, but I haven't found a proper way to enable the touchpad.

I once tried something I can't recall the name.

Does any one have any suggestions?

Update: Here's what cat /usr/share/X11/xorg.conf.d/50-synaptics.conf shows:

# Example xorg.conf.d snippet that assigns the touchpad driver
# to all touchpads. See xorg.conf.d(5) for more information on
# InputClass.
# DO NOT EDIT THIS FILE, your distribution will likely overwrite
# it when updating. Copy (and rename) this file into
# /etc/X11/xorg.conf.d first.
# Additional options may be added in the form of
#   Option "OptionName" "value"
Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
# This option is recommend on all Linux systems using evdev, but cannot be
# enabled by default. See the following link for details:
      MatchDevicePath "/dev/input/event*"
share|improve this question

closed as too localized by Jorge Castro, Ringtail, fabricator4, Luis Alvarado, Tom Brossman Jan 6 '13 at 7:22

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Does this work? -… – James Feb 2 '12 at 12:38
@jrg Sorry, but seems not :( Is there a way to check if I did it right ? – Spirit Zhang Feb 2 '12 at 12:58
Did you reboot your computer? The changes don't take affect until after that – James Feb 2 '12 at 12:59
@jrg Yes I did reboot, but it seems not working. – Spirit Zhang Feb 2 '12 at 13:26
Do you actually have a synaptics trackpad? What does cat /usr/share/X11/xorg.conf.d/50-synaptics.conf tell you? – James Feb 2 '12 at 13:45

Open the Software Center and search for synaptics, should have a couple of packages that after install should enable your touchpad.

I had the same problem on a Dell Inspiron 1545!

share|improve this answer
Can you give more detail about which software to install ? I searched for synaptics but only got three seemingly pointless packages. – Spirit Zhang Feb 3 '12 at 0:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.