Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

If I try to copy-paste a large amount of text (from Firefox to LibreOffice), the amount of text thus copied is truncated. What setting / application imposes this limit (I assume it is the DE)? And is there anyway to increase the size of the clipboard?

share|improve this question
    
Which DE are you using?. Are you using some clipboard manager (like Klipeer)?. –  Javier Rivera Feb 2 '12 at 12:20
    
Gnome-Shell 3.2.1 –  Benjamin Feb 2 '12 at 12:31

3 Answers 3

up vote 3 down vote accepted

You can use GLIPPER which is Klipper's Gnome Cousin. Click here Glipper (Install link)

Some of the features are:

  • Will not truncate your data. At least I tested by copying from my Blog a whole post that was 3387 words total.

  • You can have a maximum of 1024 entries (Klipper can have 4096). But I think that having 100 is enough.

  • Very easy to use, just highlight some text and done. You do not need to copy it. Just highlighted it.

enter image description here

After installing it you need to logout/login to make it show on the panel.

share|improve this answer
    
Ah thanks. But so much disappointment seeing LibreOffice can't handle pasting 8 pages of plain text :( –  Benjamin Feb 2 '12 at 14:40
1  
I tested right now on LibreOffice pasting (without glipper) 37 pages of text. It worked. Then I tested highlighting 52 pages with glipper, rebooted the pc and then selected the text from glipper and paste that on LibreOffice. It worked. It was 17555 words total. So maybe the problem is another. What version of LO or something to that effect. –  Luis Alvarado Feb 2 '12 at 15:10
    
You are right it seemed to have something to do with my document's format (after clearing format it accepted the paste). –  Benjamin Feb 2 '12 at 16:48

I've been using parcellite for a while and I'm quite happy with it.

In the preferences menu, behavior tab, the Max Data Size (MB) option seems to address your problem (according to the tooltip, 0 means no limit)

share|improve this answer
    
Nice: so I begin to understand the default clipboard (x-clipboard?) cannot be configured (not explicit in man page at least and not setting in gconf), but instead it must be overridden by an other program like Parcellite or Glipper? –  Benjamin Feb 2 '12 at 14:26

You can try to install GPaste. It's a clipboard manager for gnome-shell that let you set some options.

I can't check it easily (no Gnome-Shell installed), so feel free to downvote or notify me if it doesn't work.

share|improve this answer
    
This is merely the extension (which I don't really want to have on my screen). However I'm interesting in knowing what application or module the extension is working with. This may suggest there are settings (perhaps in gconf) I could change to extend clipboard history? –  Benjamin Feb 2 '12 at 13:16
1  
Sorry, but in a quick read of the source, it looks like it doesn't change any general setting. It does use some dconf settings, but they look all private (to the app) to me, it looks like it only stores (and retrieve) its own configuration. –  Javier Rivera Feb 2 '12 at 14:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.