Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i installed skype wiht the amd64.deb file that i downloaded from skype.com
but when i click it via dash it wont start.
after that i tried it from the gnome-terminal i get this
i have a dutch Ubuntu i translated it(well i hope)

bash: /usr/bin/skype:File or directory does not exist


i remove it using sudo apt-get remove
i then installed it again using

sudo dpkg -i skype-ubuntu_2.2.0.35-1_amd64.deb

but again same problem

i checked in the /usr/bin there is a skype file and the permissions where -rwxr-xr-x 1 root root 21362968 2011-06-08

share|improve this question
    
can you do a ls -la /usr/bin/skype ? Do you have execute permissions? I have skype up and working on my amd64 system. –  Michael K Feb 2 '12 at 10:46
    
-rwxr-xr-x 1 root root 21362968 2011-06-08 12:26 /usr/bin/skype i am not familiar with those -rwxr-xr-x commands. –  blade19899 Feb 2 '12 at 10:51
    
@blade19899 Please edit info into the question itself, do not respond via comments, thanks –  Jjed Feb 2 '12 at 10:52
    
@blade19899 check 32 bit , will work ok –  One Zero Feb 2 '12 at 11:23
    
i got skype up and running i installed a while ago super-os-repo-0.4.004.deb which has a skype*.deb in its repository i deleted it and super-os-repo-0.4.004.deb and run sudo apt-get update/upgrade/autoremove/check/autoclean/clean/ and so on then i installed skype from the official repository and no problems :) –  blade19899 Feb 2 '12 at 17:15

2 Answers 2

up vote 1 down vote accepted

Skype is in fact a 32-bit program even if it's packaged for 64-bit. When downloading Skype from skype.com, you won't install the necessary 32-bit compatibility libraries on Ubuntu Oneiric. The error is a bit misleading, but it means that 32-bit compatibility libraries are not installed on a 64-bit machine.

The recommended method to install Skype is throught the Partner repository.

  1. Uninstall the Skype package using the Software Center. If you cannot find it, open a terminal and run:

    sudo apt-get purge skype
    
  2. Enable the partner repository
  3. Refresh the packages information and install Skype from the Software Center (package "skype")
share|improve this answer

it seems to me file's executable bit's are set, even then, set the execution permission something like sudo chmod 777 /usr/bin/skype Or alternatively why don't you try it installing from Ubuntu Software Center or Synaptic? this way Ubuntu will install a compatible version on your machine, and as @one-zero said try installing 32 bit.

share|improve this answer
    
Ubuntu Software Center doesn't have 64 bit version mean there is something ... –  One Zero Feb 2 '12 at 11:30
    
-1 chmod 777 ? –  Lekensteyn Feb 2 '12 at 11:35
    
I meant check that executable bits are set –  Ravish Tiwari Feb 2 '12 at 13:49
    
The correct way to add the executable bit is with chmod +x file. That respects the umask and does not unnecessary add write permissions which can lead to an insecure system –  Lekensteyn Feb 2 '12 at 14:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.