Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently I installed Firefox 10.00 after which it crashes when I start it. It reported that

GLXtest process failed (exited with status 1): GLX version older than the required 1.3

My glx info

glxinfo | grep version
server glx version string: 1.2
client glx version string: 1.4
GLX version: 1.2
OpenGL version string: 1.4 Mesa 7.7.1

How to update it?

share|improve this question

closed as off-topic by bain, Eric Carvalho, Lekensteyn, bodhi.zazen, Jorge Castro Jun 30 at 19:57

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

I had the same problem. Here is how to fix it.

You might want to read this discussion.

The bottom line is you should install newer Xorg packages and one way to get them is to use the xorg-edgers ppa. Check this link.

If you have not much idea how to install ppa please do some web searches.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.