Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently my system has been suffering from what appear to be numerous hardware defects. Most critically, my system has apparently been overheating (under medium load) and summarily shutting down. One factor which I have already discovered is that the back fan is not spinning. It appears to just be broken because voltage readings (with a volt meter, not sensors) on its pins show 12V. I suspect, though, that the fan isn't my only problem.
How can I determine the extent of my hardware damage using acpi, sensors or other tools? I am getting numerous bad readings and I'm not sure whether they correspond to hardware failures, nonexistent sensors or just misconfigured measurement software.

Sensors:

sensors
coretemp-isa-0000
Adapter: ISA adapter
ERROR: Can't get value of subfeature temp1_input: Can't read
Core 0:       +0.0°C  (high = +86.0°C, crit = +100.0°C)  ALARM  

coretemp-isa-0001
Adapter: ISA adapter
ERROR: Can't get value of subfeature temp1_input: Can't read
Core 1:       +0.0°C  (high = +86.0°C, crit = +100.0°C)  ALARM  

f71882fg-isa-0a00
Adapter: ISA adapter
+3.3V:       +3.36 V
in1:         +1.22 V  (max =  +2.04 V)   
in2:         +1.02 V
in3:         +0.86 V
in4:         +0.96 V
in5:         +1.10 V
in6:         +0.90 V
3VSB:        +3.36 V
Vbat:        +3.04 V
fan1:        868 RPM
fan2:          0 RPM  ALARM
fan3:          0 RPM  ALARM
fan4:          0 RPM  ALARM
temp1:       +89.0°C  (high = +85.0°C, hyst = +81.0°C)  ALARM  
                      (crit = +100.0°C, hyst = +96.0°C)  sensor = transistor
temp2:       +33.0°C  (high = +85.0°C, hyst = +81.0°C)  
                      (crit = +100.0°C, hyst = +96.0°C)  sensor = transistor
temp3:         FAULT  (high = +70.0°C, hyst = +68.0°C)  
                      (crit = +85.0°C, hyst = +83.0°C)  sensor = transistor

and unhelpfully:

acpi -V
No support for device type: power_supply
No support for device type: power_supply
Cooling 0: Processor 0 of 0
Cooling 1: Processor 0 of 7

Using the KDE plasma widget I can see that temp1 fluctuates between 89-92 while temp2 reads a constant 33 (ie, it's broken). I never really paid much attention to this until my computer starting getting unnaturally slow under medium loads and summarily dying. Then I saw that dmesg was littered with

[ 1561.568839] CPU1: Core temperature above threshold, cpu clock throttled (total events = 1)
[ 1561.568857] CPU0: Core temperature above threshold, cpu clock throttled (total events = 1)
[ 1800.040047] Machine check events logged

I don't have much experience with deciphering temperature readings or generally sniffing out bad hardware--could this whole phenomenon really be explained by a dead back fan? I've taken off one of the box panels (which would seem to offer about as much extra ventilation as the little 4" fan) and the CPU, PSU and front-of-the-box fans are all running on full duty cycle but it doesn't seem to make any difference. I'm still getting very high temp readings and frequent shutdowns. What can I do?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

This is not a ubuntu question, however, I try to help you:

  • opening the housing of the PC usually makes it worse, however, you can use a big ventilator and place it in fromt of the open side

  • dirty coolers are usually a problem - remove all the dust

  • best idea, but you need some experience: remove the CPU cooler, clean everything and remount it with few (not too much) thermal compound cream. Make sure that the cooler is fixed on the CPU (maybe even the clip released itselt over the time.

share|improve this answer
    
I followed your instructions and the improvement is dramatic. I took everything apart, cleaned it, and reaffixed the CPU cooler. My original question was if there were good ways to use software to troubleshoot the problem beyond what I posted (and as such I believe that it was a ubuntu question) but I guess the answer is no. Since your answer ultimately solved my problem, I'm accepting it. –  mmdanziger Feb 5 '12 at 16:10
    
In this case, the answer is no. There wont be a tool which sais you that you have to remount your CPU cooler. However, if your CPU gets too hot it is obvious that the cooling is not okay anymore.Those three points are the three things to ckeck. I HOPE YOU DID USE THERMAL COMPOUND (its a white cream) to remount the Heat-Sink. This is important because it improves the heat transportation between CPU and Heatsink drastically. Without your CPU could get damaged sooner or later! –  Michael K Feb 6 '12 at 6:36
    
Yea, this time around I did it right: air in a can for dust, alcohol to clean the residue, new thermal grease. I was hoping there were some better sensors results that could tell me if there was really a thermal problem or if the sensors were broken. Following your advice, I bet on the problem being real and was correct: I'm getting temps of 32-38 instead of 89-92 and no spontaneous dying. –  mmdanziger Feb 6 '12 at 10:15
    
usually the sensors are relieable.So if your car shows the "fuel tank nearly empty light" then you also dont think: hm maybe the sensor is broken, lets drive on for 250 more kilometers :-D –  Michael K Feb 6 '12 at 13:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.