Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I switched from Gnome/Unity to LXDE on my netbook because it has only 1 GB RAM. Now the Kile window has no menu bar. How does one get it back?

This does not affect all KDE applications - for example, Kate does have a menu bar.

share|improve this question
    
do you have a file & folder called .kde/share/config/kilerc - what happens if you rename this file i.e. to reset kile's settings? –  fossfreedom Feb 15 '12 at 11:43
    
Yes, renaming this file (resetting settings) brings back the menu bar. I'd like a way to do this without modifying other settings, though. –  Prateek Feb 15 '12 at 12:59
1  
ok... it sounds like a corruption in the file itself - I think its a text file so you should be able to compare your old file with your newly regenerated file to see what the issue is. I think it would be useful if you can pastebin.com both your existing kilerc file and a newly regenerated file to compare with. –  fossfreedom Feb 15 '12 at 13:08
add comment

3 Answers 3

up vote 12 down vote accepted

In ~/.kde/share/config/kilerc, look for the section [KileMainWindow], and within that look for the line menubar=Disabled. Change Disabled to Enabled or delete this line.

Thanks to @fossfreedom for suggesting looking in ~/.kde/share/config/kilerc.

share|improve this answer
    
thanks I add the same issue for a long time but using ubuntu+gnome-shell, this fixed it :) –  Victor P. Apr 6 '12 at 8:55
add comment

converted comment to answer

A similar issue was reported on ubuntuforums.

In this case it was reported against Kubuntu - so the observation that you have switched to LXDE perhaps is not the key issue here.

The resolution was to rename the file ~/.kde/share/config/kilerc.

This file will then be regenerated when you next start Kile.

This will result in your own customisation settings being lost but user-defined shortcuts are retained.

share|improve this answer
add comment

If you do not want to destroy your settings:

  • Open the file ~/.kde/share/config/kilerc with an editor.
  • Look for [KileMainWindow].
  • Change the setting MenuBar=Disabled to MenuBar=Enabled.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.