Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I downloaded the latest Netbeans installer (6.9) which is not yet available on 10.04.

I tried to

"sudo ./netbeans-6.9-ml-linux.sh" 

but it does not install anything. I get the following messages before the installer quits silently:

Configuring the installer...
Searching for JVM on the system...
Extracting installation data...
Running the installer wizard...
share|improve this question
add comment

4 Answers 4

up vote 2 down vote accepted

At a guess you probably need a pre-requisite the Sun JDK rather than the OpenJDK delivered by default. You'll find it in the Canonical Partner repository. Here's a blog post which talks about it:-

http://www.clickonf5.org/linux/how-install-sun-java-ubuntu-1004-lts/7777

share|improve this answer
    
I did install the SUN JDK before the installation. That was my first instinct too, but I'm afraid that is not the issue. –  pablo Aug 5 '10 at 9:24
    
Hmmm, Now I see that the java symbolic link was not updated. Maybe that's the issue. –  pablo Aug 5 '10 at 9:29
    
That was it. Install the SUN JDK and replace the java symbolic link. –  pablo Aug 5 '10 at 9:36
    
Nope ! any one can run netbeans on openjdk. I was running netbeans 7.1 on OpenJDK without any problem. Now im downgraded to netbeans 7.0.1 as I feel the javaFX tool in netbeans 7.1 is useless on ubuntu. –  Curious Apprentice Apr 19 '12 at 9:51
add comment

I have experienced been some problems with the Netbeans installer not displaying properly on the Ubuntu Netbook remix. The same problem some times happens if you have the 3D effects on your desktop (Compiz).

You can start netbeans using the MToolkit (or add to the start up script)

AWT_TOOLKIT=MToolkit /usr/local/netbeans-6.5/bin/netbeans

Or just turn off compiz whilst you install netbeans.

If you run the netbook remix, logout and select the Gnome session before login back in again and you have the normal desktop. You should then be able to install netbeans.

I also had a problem with running netbeans under the netbook remix, having to either unmaximise netbeans or run in full screen.

Have a look at the community information for Netbeans on Ubuntu.

share|improve this answer
add comment

Its not clear which symbolic link you replaced, but if you have more than one java virtual machine installed, its recommended to manage them with the alternatives system in Ubuntu (debian).

To see the list of installed java virtual machines on you system, run the command:

sudo update-java-alternatives -l

To set the sun java virtual machine to the be the one used, then use the command:

sudo update-java-alternatives -s java-6-sun 

Changing symbolic links could cause you problems if there is a package update and the link get reinstated by the package manager.

Have a look at the Java on Ubuntu page for more details.

share|improve this answer
    
Great information. Thanks! –  pablo Aug 5 '10 at 11:34
add comment

Check for any "netbeans" folder in /usr/local. It might the launcher which is not correctly created.

If u have updated openjdk6 to openjdk7 then revert back to openjdk6.

Check whether you have the correct java path variable association. I use java and javac on terminal to check java installaion. Just open terminal and type "javac" and hit enter. If there is some problem nothing will show up.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.