Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Firefox is not showing in system-settings - system info. So I cannot use the menu to choose it.

(I don't want to seem off-topic but I think a little background would be helpful here: The previous Ubuntu version of Firefox was crashing my system all the time so I uninstalled it. I then manually installed the Mozilla version of Firefox 10 which is running well. But if I click on the Check Now button in Firefox's Advanced Preferences then nothing happens, and the dialog that should appear asking me if I'd like to make it the default browser does not show up.)

Is there a config file or something I can edit to make Ubuntu aware that Firefox exists on my system, and allow me to set it as my default browser?

I'm using ubuntu 11.10

share|improve this question

closed as off topic by jrg May 22 '12 at 18:45

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
If the Ubuntu version of Firefox keeps crashing your system, you may want to file a bug against it on Launchpad so the developers are aware of the issue. –  WarriorIng64 Feb 2 '12 at 11:28
    
I'll happily report a bug, but I don't know how helpful I could be with that. I don't know exactly what was causing the crashes, and I assume developers don't like bug reports without much detail. Since the whole system crashed, I guess it might be something to do with the way the system is interracting with Firefox, because if it were Firefox itself crashing then I'd suppose that it wouldn't take the whole system with it? –  dunderhead Feb 2 '12 at 11:47
    
Some sort of report is better than no report. Just make sure when you file it that you try to include as many details as possible about the nature of the problem, especially steps to reproduce it if you can. If the developers need any additional information from you, they'll let you know in a comment on the report. –  WarriorIng64 Feb 2 '12 at 13:52
1  
This question should instead be filed as a bug report, and as such is off-topic, thanks! Instructions here. –  RolandiXor Feb 2 '12 at 19:04
1  
Roland - I filed this as a bug report but got a reply that it was invalid, and as I was not using software from the repositories I should take up the issue with the software with the provider of the software package. When I first learned of Ubuntu everyone was positive about it. But now it seems there are people who are not so happy (who often get called trolls) and I can see why. Remember when Microsoft tightly integrated Internet Explorer with the operating system and people weren't happy? So why has Ubuntu done this with Firefox? Why can't we have a plain install as in Ubuntu 10? –  dunderhead Mar 19 '12 at 6:38

5 Answers 5

Run in a terminal:

sudo update-alternatives --config x-www-browser

The output should look like this:

There are 3 choices for the alternative x-www-browser (providing /usr/bin/x-www-browser).

  Selection    Path                       Priority   Status
------------------------------------------------------------
* 0            /usr/bin/epiphany-browser   85        auto mode
  1            /usr/bin/chromium-browser   40        manual mode
  2            /usr/bin/epiphany-browser   85        manual mode
  3            /usr/bin/firefox            40        manual mode

Press enter to keep the current choice[*], or type selection number: 3
update-alternatives: using /usr/bin/firefox to provide /usr/bin/x-www-browser (x-www-browser) in manual mode.

Choose what you want to set as default.

share|improve this answer
    
Thanks One Zero but the output of that is: There is only one alternative in link group x-www-browser: /usr/bin/chromium-browser Nothing to configure. –  dunderhead Feb 2 '12 at 8:13
    
# which firefox output ? –  One Zero Feb 2 '12 at 8:21
    
Sorry, I'm not sure if I understand One Zero. The output of sudo update-alternatives --config x-www-browser gives: There is only one alternative in link group x-www-browser: /usr/bin/chromium-browser Nothing to configure. –  dunderhead Feb 2 '12 at 9:08
    
Another weird thing: Firefox does not appear in the alt-tab task switcher! Even though it's running (I'm typing this in Firefox now) it appears that Ubuntu cannot see Firefox... –  dunderhead Feb 2 '12 at 9:11
1  
Thanks One Zero, but I don't want to install the Ubuntu Firefox because it just kept crashing. (I don't want to go off-topic but I noticed a problem with Zeitgeist and Firefox eating up huge percentages of memory and processor cycles. I'm really not sure if it's the Unity integration or some oher thing that's causing the problem, but since I've been running the generic Mozilla vesion my system has been stable again, so I really do not want to install the Ubuntu version again and have the problem reappear.) –  dunderhead Feb 2 '12 at 10:14

I had problem with mozillateam ppa for firefox-stable.

This will do the trick

sudo add-apt-repository ppa:mozillateam/firefox-next
sudo apt-get update
sudo apt-get install firefox # (even if you have `firefox` installed)  

You will have the latest version of Firefox which is currently v 10.

Then try System Settings → System Info → Default Applications. There change the Web. Firefox must be there this time.

share|improve this answer
    
Thank you Ivan! This did indeed get Firefox back into System Settings > System Info > Default Applications. Now I am able to run the Mozilla version (10) I had installed and it behaves as the default browser! (BTW the PPA installed Ubuntu version 11. As someone who is forced to sometimes also use Windows I find the Unity global menu too much of a pain and so turned it off, but the Ubuntu version of Firefox overrides this and uses the global menu - an inconsistency and yet another reason why I don't want the integrated version of Firefox.) I'd still like to know the manual method tho'... –  dunderhead Feb 4 '12 at 18:01

The software centre version of Firefox has Ubuntu Firefox Modifications to enable it to work and integrate with Ubuntu better. The linux version you can download from Mozilla direct does not have this add on so that is likely the reason why you cannot integrate it into the system as you wish.

enter image description here

I guess your option here is to live with what you have or try and install the Ubuntu version and troubleshoot the issues with it.

share|improve this answer
    
...check down the comments in my answer ,he got some problem with software center Firefox , as u said i m totally agree –  One Zero Feb 2 '12 at 11:28

You can go to System Settings > System Info > Default Applications. There change the Web.

share|improve this answer
2  
Sorry Ivan but that does not work! As I stated in my original post: "Firefox is not showing in system-settings - system info. So I cannot use the menu to choose it." –  dunderhead Feb 2 '12 at 8:11

This doesn't precisely answer the question you asked, but should neatly side-step it and save you trouble in future, I hope:

Install the "official" firefox package from here: https://launchpad.net/~mozillateam/+archive/firefox-stable

Bacically, you just register the PPA in your machine's "software sources" and then install Firefox from the software centre (make sure it's refreshed its package list first), and you'll get the latest and greatest, and the updates will come automatically along with the rest of the packages.

share|improve this answer
    
Thanks ams, but that says it's for Maverick and Lucid, but I'm using Oneiric - will it work for me too? –  dunderhead Feb 2 '12 at 18:13
    
Quite right, I hadn't spotted that. Sorry. It appears that there are no PPAs with the latest firefox for Oneiric because the official repository already has them. My Oniric install currently has Firefox 9.0.1 which seems quite respectable since Firefox 10.0 has only been out 3 days. No doubt there'll be any update soon. I had forgotten that I hadn't needed that PPA in a while. –  ams Feb 3 '12 at 9:43

Not the answer you're looking for? Browse other questions tagged or ask your own question.