Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I have made some changes in system settings, following suggestions by some users. However, this morning when I did a reboot I am unable to see English as my default language. My system is showing some Chinese characters which I do not understand.

All I wanted was to use Libre Office for a particular document in Hindi. What happened is that even Gmail is opening in Chinese. The system settings folder and others are also opening in Chinese. I am unable to use the system now.

I have uploaded the snapshots here: please have a look.

Notice that in the third snapshot the calendar and menu are appearing in Chinese.

I want the original US English menus and folder names back. I just wanted to type a document with Lohit Hindi font in Libre Office.

I use Ubuntu 11.10. I do not use Unity, only Gnome desktop. I installed gnome-session-fallback a long time back and have been using that ever since.

How do I get back to all English submenus and English folder names? I have a US English Keyboard and I use only US English. This thing which is now somehow set is unwanted.

share|improve this question
    
maybe try setting all entries in the file /etc/default/locale to en_US.UTF-8 –  Michael K Feb 2 '12 at 6:21
    
@MichaelK I have uploaded a snapshot here that setting is already what you are saying but the problem still is there picasaweb.google.com/107404068162388981296/… –  Registered User Feb 2 '12 at 7:37
add comment

marked as duplicate by Tachyons, Luis Alvarado Apr 19 '13 at 16:27

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3 Answers

I had my account mysteriously change to Chinese after an update today - this is 12.04.

The problem was in .pam_environment: I changed all zh_CN to en_GB and logged back in again.

I will note that when the pop-up thing says 'Oooh, you've changed your language, do you want to rename all your directories', just perhaps there should be a very obvious option 'Oh no, I didn't mean for that to be magically inflicted upon me by some weird configuration mistake, please keep my language settings as they were!'.

If there was one, I didn't notice it, so it's probably not obvious enough.

share|improve this answer
add comment
up vote 5 down vote accepted

I noticed in files /etc/environment, $HOME/.profile following lines were present:

export LANGUAGE="zh_CN:en"
export LC_MESSAGES="zh_CN.UTF-8"
export LC_CTYPE="zh_CN.UTF-8"
export LC_COLLATE="zh_CN.UTF-8"

and in /etc/default/locale only US English line was present as you can see this snapshot:

I went to those files and deleted these extra lines of Chinese Language now I am able to resolve this problem and things are back on track.

However specially want to mention that gnome-language-selector did not help at all.

Sharing this for future archives hope this solution will help some one in future.

share|improve this answer
add comment

edit your file

/etc/default/locale

in there change all settings to

en_US.UTF-8

share|improve this answer
    
I have uploaded a snapshot here that setting is already what you are saying but the problem still is there picasaweb.google.com/107404068162388981296/… –  Registered User Feb 2 '12 at 7:39
    
as per a suggestion here ubuntuforums.org/showthread.php?t=1918968 I had opened gnome-language-selector but I was stuck here in following steps step 1 picasaweb.google.com/107404068162388981296/… step 2 picasaweb.google.com/107404068162388981296/… –  Registered User Feb 2 '12 at 8:02
    
just click one of the buttons :-D –  Michael K Feb 2 '12 at 8:08
    
well I had clicked one of those buttons but there was no change upon even selecting english. –  Registered User Feb 2 '12 at 9:04
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.