Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How do I reset a lost Administrative(root) password?

I decided to turn off the password.

A couple days after this I tried downloading a webcam app and it asks me for my password. I tried my old passwords but it gets denied.

Online I found an explanation on how to restore my password. I go through all the steps and it asks for me to enter new UNIX password, so I enter in a new password there. It prompts me to enter it again so I do and then it says authentication manipulation error, then in the line below it, it says password unchanged.

Is there a way to fix this or will I have to reinstall Ubuntu?

share|improve this question
    
did you try typing just nothing and click okay? –  Michael K Feb 2 '12 at 9:36
add comment

marked as duplicate by bodhi.zazen, Bruno Pereira, Jorge Castro, RolandiXor, Takkat Feb 2 '12 at 19:57

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

Try turning on caps lock. On occasion people press this when putting in a password.

If this doesn't work then start up with a live CD. You'll then need to get into the shadows file and delete your password hash. This should force it to blank.

share|improve this answer
    
Can you elaborate on how to get into and edit the shadows file? –  WarriorIng64 Feb 2 '12 at 11:31
    
Edit /etc/shadow and MAKE SURE you read the SHADOW(5) man page first. –  Brandon Weaver Feb 2 '12 at 19:04
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.