Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a problem adding my Ubuntu server to AD. I followed this great tutorial but it fails on join command: sudo domainjoin-cli join myDomain.com Administrator.

It gives me this error:

Error: DNS_ERROR_BAD_PACKET [code 0x0000251e]

A bad packet was received from a DNS server. Potentially the requested address does not exist.

A can ping myDomain.com from server just fine.

How can I solve this?

share|improve this question

migrated from webmasters.stackexchange.com Feb 2 '12 at 2:10

This question came from our site for pro webmasters.

    
This would probably be better suited for AskUbuntu.com, or one of the other Unix/Server Stack Exchange sites. –  Windigo Feb 1 '12 at 16:37
add comment

2 Answers 2

I had the same issue once and it was because I had 2 NICs. One for this network and another for internet access (was using VMs).

Disabling the 2nd NIC allowed it to work :)

share|improve this answer
add comment

Sorry to resurrect this thread, but I found a decent fix to both the bad packet error AND the Llass error (spelling?)

I had to do 3 things:

  1. Edit the network connection IPv4 settings. Add the IP of your domain host to the DNS server list (if your server manages domain and DNS) in the additional DNS section. NOTE: If you have multiple NICs in the machine, make sure you are editing the settings for the correct adapter, the interface managing the host/DNS or this won't work!

    Add your domain name to the host setting directly below the additional DNS. This may be redundant, but this is how I set it. For example, mydomain.something.local

  2. Edit the /etc/hosts file and just add the IP address of the DNS server at the top of the file, or directly before the "127.0.0.1 localhost" line.

    192.168.1.231
    
    127.0.0.1 localhost
    
  3. Edit the /etc/nsswitch file and make these two lines read as follows:

    hosts:          files dns
    
    networks:       files
    

Reboot the machine and try connecting again. It should work.

(Remember to back up your original files in case you need to roll it back.)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.