Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Ubuntu 11.10. I used a wired connection to download and install all of the updates.

When I tried to use a Netgear WNA3100 wireless USB network adapter, it failed. Much searching and trying things I was finally able to get it working by disabling security on my router. I have verified this by disabling security and I was able to connect. When I enabled security (WPA2 PSK), the connection failed.

What is necessary to enable security (WPA2 PSK) and still use the Netgear USB interface?

Here is the output from the commands most requested

lsusb

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 0846:9020 NetGear, Inc. WNA3100(v1) Wireless-N 300 [Broadcom BCM43231]

lshw -C network

  *-network               
       description: Ethernet interface
       product: RTL-8139/8139C/8139C+
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 3
       bus info: pci@0000:02:03.0
       logical name: eth0
       version: 10
       serial: 00:40:ca:44:e6:3e
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=8139too driverversion=0.9.28 duplex=half latency=32 link=no maxlatency=64 mingnt=32 multicast=yes port=MII speed=10Mbit/s
       resources: irq:19 ioport:c800(size=256) memory:ee011000-ee0110ff memory:40000000-4000ffff
  *-network
       description: Wireless interface
       physical id: 1
       logical name: wlan0
       serial: e0:91:f5:56:e1:0d
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=ndiswrapper+bcmn43xx32 driverversion=1.56+,08/26/2009, 5.10.79.30 ip=192.168.1.104 link=yes multicast=yes wireless=IEEE 802.11g

iwconfig

lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11g  ESSID:"vincecarolradice"  
          Mode:Managed  Frequency:2.422 GHz  Access Point: A0:21:B7:9F:E5:EE   
          Bit Rate=121.5 Mb/s   Tx-Power:32 dBm   
          RTS thr:2347 B   Fragment thr:2346 B   
          Encryption key:off
          Power Management:off
          Link Quality:76/100  Signal level:-47 dBm  Noise level:-96 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

ndiswrapper -l

bcmn43xx32 : driver installed
    device (0846:9020) present

lsmod | grep ndis ndiswrapper 193669 0

dmesg | grep -e ndis -e wlan

[  907.466392] ndiswrapper version 1.56 loaded (smp=yes, preempt=no)
[  907.838507] ndiswrapper (import:233): unknown symbol: ntoskrnl.exe:'IoUnregisterPlugPlayNotification'
[  907.838955] ndiswrapper: driver bcmwlhigh5 (Netgear,11/05/2009, 5.60.180.11) loaded
[  908.137940] wlan0: ethernet device e0:91:f5:56:e1:0d using NDIS driver: bcmwlhigh5, version: 0x53cb40b, NDIS version: 0x501, vendor: 'NDIS Network Adapter', 0846:9020.F.conf
[  908.141879] wlan0: encryption modes supported: WEP; TKIP with WPA, WPA2, WPA2PSK; AES/CCMP with WPA, WPA2, WPA2PSK
[  908.143048] usbcore: registered new interface driver ndiswrapper
[  908.178826] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  994.015088] usbcore: deregistering interface driver ndiswrapper
[  994.028892] ndiswrapper: device wlan0 removed
[  994.080558] ndiswrapper version 1.56 loaded (smp=yes, preempt=no)
[  994.374929] ndiswrapper: driver bcmn43xx32 (,08/26/2009, 5.10.79.30) loaded
[  994.404366] ndiswrapper (mp_init:219): couldn't initialize device: C0000001
[  994.404384] ndiswrapper (pnp_start_device:435): Windows driver couldn't initialize the device (C0000001)
[  994.404666] ndiswrapper (mp_halt:262): device e05b6480 is not initialized - not halting
[  994.404671] ndiswrapper: device eth%d removed
[  994.404709] ndiswrapper: probe of 1-5:1.0 failed with error -22
[  994.406318] usbcore: registered new interface driver ndiswrapper
[ 2302.058692] wlan0: ethernet device e0:91:f5:56:e1:0d using NDIS driver: bcmn43xx32, version: 0x50a4f1e, NDIS version: 0x501, vendor: 'NDIS Network Adapter', 0846:9020.F.conf
[ 2302.060882] wlan0: encryption modes supported: WEP; TKIP with WPA, WPA2, WPA2PSK; AES/CCMP with WPA, WPA2, WPA2PSK
[ 2302.113838] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 2354.611318] ndiswrapper (iw_set_auth:1602): invalid cmd 12
[ 2355.268902] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 2365.400023] wlan0: no IPv6 routers present
[ 2779.226096] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 2779.422343] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 2797.574474] ndiswrapper (iw_set_auth:1602): invalid cmd 12
[ 2802.607937] ndiswrapper (iw_set_auth:1602): invalid cmd 12
[ 2803.261315] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 2813.952028] wlan0: no IPv6 routers present
[ 3135.738431] ndiswrapper (iw_set_auth:1602): invalid cmd 12
[ 3139.180963] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 3139.816561] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 3163.229872] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 3163.444542] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 3163.758297] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 3163.860684] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 3205.118732] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 3205.139553] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 3205.300542] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 3353.341402] ndiswrapper (iw_set_auth:1602): invalid cmd 12
[ 3363.266399] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 3363.505475] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 3363.506619] ndiswrapper (set_iw_auth_mode:601): setting auth mode to 5 failed (00010003)
[ 3363.717203] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 3363.779206] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 3405.206152] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 3405.248624] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 3405.577664] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 3438.852457] ndiswrapper (iw_set_auth:1602): invalid cmd 12
[ 3438.908573] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 3568.282995] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 3568.325237] ndiswrapper (set_iw_auth_mode:601): setting auth mode to 5 failed (00010003)
[ 3568.460716] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 3568.461763] ndiswrapper (set_iw_auth_mode:601): setting auth mode to 5 failed (00010003)
[ 3568.809776] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 3568.880641] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 3610.122848] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 3610.148328] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 3610.324502] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 3636.088798] ndiswrapper (iw_set_auth:1602): invalid cmd 12
[ 3636.712186] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 3647.600040] wlan0: no IPv6 routers present

I am using the system now with the router security turned off. When I submit this, I will turn security back on.

share|improve this question
    
I updated to ndiswrapper v 1.57. Still not working. I am trying to install the STA drivers from Broadcom but I can't figure out where to copy the wl.ko file to. The README is not specific enough. I have tried to put it in several different places and use modprobe to get it installed (per the instructions) but modprobe says it can't find the module when it is it the dircetory where I issue the command. –  Vince Radice Feb 4 '12 at 16:23
    
As of time of writing, this problem exists for 12.04. –  Ryan McClure May 9 '12 at 22:48
add comment

1 Answer 1

I just found out how to connect to mine; however, it may not be a universal solution. Give it a shot and let's see if it works for you. On your router, change the WPA2 setting to TKIP and not AES. As soon as I did that, it instantly connected. So, I hope it helps you!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.