Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have never got my head around the boot loaders and stuff.

I have three partitions C:, D: and E. I installed Ubuntu inside Windows (wubi) on the second drive D:. Yesterday I made an another partition G: and installed Fedora16 onto it. During the installation I installed the boot loader in MBR from /dev/sda. Now the default boot loader is GRUB.

But grub doesn't show Ubuntu in the menu.I have all my scripts in my Ubuntu home folder which is now inaccessible. How do I add the Ubuntu entry into grub??

Do I revert to the windows boot loader and add the Ubuntu entry using the easybcd program?? btw windows is the primary OS and is installed in the C drive I am a student and relatively new to Linux.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

This is how it works with my Ubuntu 11.10-Windows 7-Wubi install.

My GRUB menu has entries for 11.10 (which is its own partition), as well as my Windows 7.

When I want to access my Wubi install, I select Windows, and then there is another entry to access my Wubi install or boot Windows. Here is a video of how this works.

share|improve this answer
    
Ha! Thanks! Maybe I panicked a bit here...like you said,when grub starts up there are two entries fedora and windows,,now when I choose windows,I have two options,one to boot into windows and the other to boot into ubuntu. I should have tried booting into windows first before posting(I have like stopped booting into windows after installing linux).My bad! Btw thanks again! :) –  Phani Kumar Feb 1 '12 at 20:02
    
@PhaniKumar To be honest, I wasn't sure how it would work out the first time I did it, so you're not alone. :) –  jrg Feb 1 '12 at 22:21
2  
If you're using Grub2, then you can add a custom entry to boot the Wubi install directly (without going via the windows boot manager). But grub legacy (at least version 0.97) can't do this because it cannot loop mount the root.disk to get the kernel & initrd, and I guess fedora is still using grub legacy. –  bcbc Feb 2 '12 at 17:17

I am not so much into Fedora, but it should work like this:

Entering:

grub2-mkconfig -o /boot/grub2/grub.cfg

in Terminal should update your grub. (maybe you need to enter sudo grub2-mkconfig -o /boot/grub2/grub.cfg as I said, I am not much into fedora.)

Then boot into Windows and add Wubi-Ubuntu there via EasyBCD.

If you want to start Ubuntu:

  1. Boot your PC.
  2. Choose Windows in Fedora Bootloader
  3. Choose Ubuntu in Windows Bootloader
share|improve this answer
    
Thanks! It was my mistake that I didn't try booting into windows before posting here.It works fine without updating the grub.Selecting windows in the grub menu takes me to the windows bootloader which has windows and ubuntu entries.Thanks again! :) –  Phani Kumar Feb 1 '12 at 20:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.