Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I opened libreoffice 3.0 (Ubuntu 11.10) and selected Lohit Hindi font in the fonts selection column. Downloaded the charachter map of English and Hindi keys as given here http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5/html-single/International_Language_Support_Guide/images/hindi.png

but when I am typing in Hindi with my english keyboard there is no Hindi word I still the english letters typed as "kerasadsd".Which should not happen since Lohit Hindi font is selected so I expected the correcponding key mapped Hindi characters to appear. What mistake did I do in above? I have US English keyboard only and I am using the same to type in Hindi.

share|improve this question
    
possible duplicate of How to type Hindi in open office? –  jokerdino Apr 28 '12 at 10:41
add comment

1 Answer

Selecting a font is not enough. You need to have a proper input method also (keyboard layout).

Here is what you do: Dash - System Settings - Keyboard Layout - Layouts - Add (A small plus sign at the bottom left).

Add the one you are comfortable with.

Now, start Libreoffice, switch the keyboard layout (using the bar at the top in Gnome Shell) and you are ready to go.

share|improve this answer
    
My guess is you need the proper keyboard layout but you don't need an "input method". Input methods are used for entering languages like Chinese, Japanese and Korean. –  kyleN Feb 1 '12 at 21:45
    
Thanks deshmukh, I've been trying to get Sinhala working for a while now but never noticed the little keyboard symbol at the top of Gnome Shell. –  C.S.Cameron Feb 2 '12 at 4:58
    
@deshmukh this has increased my problem now I see an unwanted chinese language in ubuntu askubuntu.com/questions/100684/… –  Registered User Feb 2 '12 at 6:11
    
Sure, I had not noticed earlier but I also have Chinese language at the top. I am sure there is a way to resolve it. But I do not know what it is. –  deshmukh Feb 2 '12 at 17:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.