Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 11.10 today on my Lenovo w500. After that when i tried running

sudo apt-get update

This is the error i am getting.

Get:117 http://ftp.jaist.ac.jp oneiric-security/universe TranslationIndex [73 B]                                                                                                         
99% [48 Sources bzip2 0 B] [22 Sources bzip2 5,294 kB]                                                                                                                      1,983 kB/s 0s
bzip2: Compressed file ends unexpectedly;
    perhaps it is corrupted?  *Possible* reason follows.
bzip2: Inappropriate ioctl for device
    Input file = (stdin), output file = (stdout)

It is possible that the compressed file(s) have become corrupted. You can use the -tvv option to test integrity of such files.

You can use the `bzip2recover' program to attempt to recover data from undamaged sections of corrupted files.

I found the following similar question : Errors while updating Ubuntu 11.10 , But the solutions mentioned ( changing the download server, running apt-get clean, apt-get autoclean) and have also tried removing the /var/cache/apt/archives/lists direcotry.

As a result of this, I am unable to install any new packages.

share|improve this question

closed as too localized by jrg Dec 27 '12 at 17:57

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Can you update the post to include your sources.list? –  Amanda Feb 4 '12 at 2:21
    
Things seem to have fixed themselves on their own. I did not discover the cause of the errors. Here's my sources.lst : pastebin.com/raw.php?i=CUcTVy4v –  Tejas Kale Feb 6 '12 at 12:44
    
That's consistent with a mirror just being down, I guess. Sometimes mirrors go down for a while. –  Amanda Feb 7 '12 at 21:30
    
But, I tried 3 different mirrors over a period of 4 days, and still got the same error. I guess there was some file corruption on all the mirrors, or I am damn unlucky. –  Tejas Kale Feb 8 '12 at 5:17
    
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. :) –  Seth Dec 27 '12 at 17:51
add comment

1 Answer 1

That is an unusual repository to include.

Start by disabling that particular repository.

The easy way is to launch Synaptic and go to Settings > Repositories -- jaist.ac.jp will be under Other Software. Uncheck it to disable it.

You can also comment it out by editing /etc/apt/sources.list and adding a # before the line that lists that repo.

share|improve this answer
    
jaist.ac.jp isn't a repository, it is the server. It is mirroring the oneiric-security repository. –  psusi Feb 1 '12 at 15:31
    
@amanda you are slightly mistaken. jaist.ac.jp Thats the url for the japan ubuntu repo. I tried different repos and still got the same error. –  Tejas Kale Feb 1 '12 at 15:32
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.