Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have notify-send and all the requirments installed, but when I run a simple command

notify-send "Test" "Test Message"

nothing happens, but if I run the same command through sudo, it works.

System processes can send notifications with no problem, so I see a popup when I join a new wireless LAN, for example.

What group do I need to be a member of in order to send notifications?

share|improve this question
add comment

2 Answers

Check the owner of the notify-osd process:

ps -e -o fname,user | grep notify-o

On my system, it is the current user. If it is not, try killing the process and restart it as current user.

share|improve this answer
    
No, notify-osd is running as me. –  Stuart Grimshaw Feb 1 '12 at 13:48
    
Are any of the following questions related? askubuntu.com/questions/16173/… askubuntu.com/questions/52960/… –  krlmlr Feb 1 '12 at 15:27
    
No, I have all the deps installed and AFAIK, I have nothing inhibiting the screensaver, it does indeed start after a period of inactivity. The fact I can run it as root just makes it feel like a problem with permissions. –  Stuart Grimshaw Feb 1 '12 at 16:24
    
Well, other people have problems running it as root... ubuntuforums.org/showthread.php?t=1727148 –  krlmlr Feb 2 '12 at 8:32
add comment

For me the problem was that there are too notifications acumulated. if you try notification-properties > prewiew. It tells you. You should restart notification-daemon:

sudo killall notification-daemon
/usr/lib/notification-daemon/notification-daemon
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.