Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having some hard time getting straight with my adobe flash plugin.

$ sudo apt-get remove --purge adobe-flashplugin flashplugin* nspluginwrapper

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'flashplugin-installer' for regex 'flashplugin*'
Note, selecting 'flashplugin-downloader' for regex 'flashplugin*'
Note, selecting 'adobe-flashplugin' for regex 'flashplugin*'
Note, selecting 'flashplugin-nonfree-extrasound' for regex 'flashplugin*'
Note, selecting 'flashplugin' for regex 'flashplugin*'
Note, selecting 'flashplugin-nonfree' for regex 'flashplugin*'
Note, selecting 'adobe-flashplugin' instead of 'flashplugin-nonfree'
Package nspluginwrapper is not installed, so not removed
Package flashplugin-installer is not installed, so not removed
Package adobe-flashplugin is not installed, so not removed
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 adobe-flash-properties-gtk : Depends: adobe-flashplugin (= 11.1.102.55-0oneiric1) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

$ sudo apt-get install --reinstall adobe-flashplugin

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  adobe-flashplugin
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 0 B/6 709 kB of archives.
After this operation, 19,0 MB of additional disk space will be used.
dpkg: regarding .../adobe-flashplugin_11.1.102.55-0oneiric1_amd64.deb containing adobe-flashplugin:
 adobe-flashplugin conflicts with flashplugin-downloader
  flashplugin-downloader:i386 (version 11.1.102.55ubuntu0.11.10.1) is present and installed.
dpkg: error processing /var/cache/apt/archives/adobe-flashplugin_11.1.102.55-0oneiric1_amd64.deb (--unpack):
 conflicting packages - not installing adobe-flashplugin
Errors were encountered while processing:
 /var/cache/apt/archives/adobe-flashplugin_11.1.102.55-0oneiric1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

EDIT: sudo apt-get remove flashplugin-downloader

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Virtual packages like 'flashplugin-downloader' can't be removed
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 adobe-flash-properties-gtk : Depends: adobe-flashplugin (= 11.1.102.55-0oneiric1) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

EDIT#2: # apt-get -f install

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  adobe-flashplugin
The following NEW packages will be installed:
  adobe-flashplugin
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 0 B/6 709 kB of archives.
After this operation, 19,0 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
dpkg: regarding .../adobe-flashplugin_11.1.102.55-0oneiric1_amd64.deb containing adobe-flashplugin:
 adobe-flashplugin conflicts with flashplugin-downloader
  flashplugin-downloader:i386 (version 11.1.102.55ubuntu0.11.10.1) is present and installed.
dpkg: error processing /var/cache/apt/archives/adobe-flashplugin_11.1.102.55-0oneiric1_amd64.deb (--unpack):
 conflicting packages - not installing adobe-flashplugin
Errors were encountered while processing:
 /var/cache/apt/archives/adobe-flashplugin_11.1.102.55-0oneiric1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Output of sudo apt-get update - https://gist.github.com/1716225

...
W: Failed to fetch http://ppa.launchpad.net/sevenmachines/flash/ubuntu/dists/oneiric/main/source/Sources 404 Not Found
...

I'm using ubuntu 11.10

Any thoughts?

share|improve this question
    
Do you have all the repositories enabled (Partners, Universe, Multiverse etc)? –  Salih Emin Feb 1 '12 at 9:20
    
er... sudo apt-get remove flashplugin-downloader && sudo apt-get install adobe-flashplugin –  hbdgaf Feb 1 '12 at 9:21
    
@SalihEmin My sources.list is here gist.github.com/1716186 –  Gundars Mēness Feb 1 '12 at 9:45
add comment

2 Answers 2

up vote 2 down vote accepted

If figured it out myself.

I run $ apt-config dump|grep Archit and it gave

APT::Architecture "amd64";
APT::Architectures "";
APT::Architectures:: "amd64";

And I fixed it with running:

$ sudo -s
# echo "foreign-architecture i386" > /etc/dpkg/dpkg.cfg.d/multiarch
# apt-get update

And then updating packages.

share|improve this answer
add comment

adobe-flashplugin conflicts with flashplugin-downloader

Please uninstall flashplugin-downloader:

sudo apt-get remove flashplugin-downloader

I suggest trying the packages flashplugin-installer respective flashplugin64-installer if you have troubles installing flash. However, your second command should succeed after removing flashplugin-downloader

share|improve this answer
1  
Not able to, that's why I'm surprised. I added output of sudo apt-get remove flashplugin-downloader in my original question. –  Gundars Mēness Feb 1 '12 at 9:32
1  
did you try sudo apt-get -f install as suggested? Do you read the output messages carefully? –  Michael K Feb 1 '12 at 9:41
    
Of course, see the output above. –  Gundars Mēness Feb 1 '12 at 9:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.