Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i'm having problem with Ubuntu 10.04 and my Ati radeon X1300. In particular i can't enable effect (compiz) because they are SLOW, and, for example, the same game (hedgewars) on the same pc run very slowly on Linux, nor in Windows.

With my old Ubuntu (9.04) i didn't have the same problem.

Does anyone help me to "configure" the right driver for my video card ? I've tested with proprietary (fglrx) and open (xorg..-ati-radeon)... Either give me some problem :(!

Thank you!

share|improve this question
    
Are you using the open source or restricted driver? Try going to the hardware drivers and disabling the proprietary one if it is enabled. For some situations the open source one is better. –  NightwishFan Oct 28 '10 at 15:50
    
Actualli i've tested with proprietary (fglrx) and open (xorg..-ati-radeon)... Either give me some problem :(! –  stighy Oct 28 '10 at 16:33
    
Do you still have the problem. Have you found how to solved the problem or considered accepting an answer that solves your problem (if any)? –  Luis Alvarado Dec 5 '11 at 18:58

3 Answers 3

up vote 2 down vote accepted

I have ATI Radeon 9600m and works very well with "r300g" driver. To install you only need to add xorg-edger PPA.

Open terminal and copy&past sudo add-apt-repository ppa:xorg-edgers/ppa and press enter. After copy&paste sudo apt-get update & sudo apt-get upgrade and press enter.

You can check which driver do you use by command glxinfo (Install: sudo apt-get install mesa-utils). Check line OpenGL renderer string. It should contain r300g. If you have software rasterizer its not OK.

share|improve this answer
    
Looking at help.ubuntu.com/community/RadeonDriver indicates that the r300g is probably a good choice for the X1300 card. (I had similar problems with an X1250, which of course likes the r600g driver.... go figure.) –  jwernerny Mar 31 '11 at 14:05

I had that problem with radeon x1500 and x1600 so I supose the solution will be the same, and you must be using de mesa driver (the open source). I don't know if it works with the propietary fglrx (didn't for me...)

Reboot, and in the grub screen where you select the OS, pres "e" over the first entry. You will acces to a manual editor for the boot command.

Go to the end of the line with the linux kernel parameters. At the end it must be something similar like "ro quiet splash" (depending on your boot settings). After the last word, and with a space between, tipe "pci=nomsi" (without the "") DON'T PRESS INTRO, because all the orders must be in the same line... if there's no space when you write the last part, it will appear down but it's considered all the same line.

Pres control+x and you'll bot with the new parameter. Try activating compiz, running some games in 3D etc... If it doesn't work don't worry, you didn't change anything and the next time you boot the parameters will be the originals.

The problem is everytime you reboot you have tu do that, so if it worked you can make it permanent installing Grub Customizer:

sudo aptitude install grub-customizer

Open it from apps, system utilities, go to preferences, general, and in the kernel parameter box put "pci=nomsi" (again, without the ""). Close, save the new parameters and reboot.

If there's any problem, just run the program again and delete the new parameter.

I wish it helps. Good luck!

share|improve this answer

Another solution (a kind of voodoo solution ), using the open source drivers is to run the following command:

gksudo gedit /etc/modprobe.d/radeon-kms.conf

and to this blank file add the following

options radeon modeset=0

Save, Exit , Reboot and your problem will be probably solved

source: http://niccolofavari.com/ubuntu-10.04-lucid-issues-with-external-monitor-and-ati-radeon-card

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.