Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 11.10 installed...

for some unknown reason it wont log me in. entering the password returns me to the login screen immediately

i googled for solution and applied the following and yet failed

  1. rm .Xauthoruty
  2. chown -R sarvesh:sarvesh /home/sarves
  3. Reinstalled xorg and lightdm.
  4. renamed sarvesh to sarvesh.old in hopes after restart it may come back up.

nothing is helping... logging in via virtual terminal and running ls /home/sarvesh says permission denied even after chown.

after reinstalling lightdm, the interface looks weird low graphics like the one in xubuntu

please help

UPDATE MANAGED TO LOGIN but now my desktop lookis like this no unity launcher or my indicators

enter image description here

share|improve this question
    
Update managed to login but now unity wont start –  sarveshlad Feb 1 '12 at 16:18

2 Answers 2

up vote 3 down vote accepted

I have same problem in 11.04. I solved it by re-installing Compiz.

  1. Open a terminal window.
  2. Type, sudo apt-get remove compiz and hit Enter
  3. Type your password if requested (nothing will show up for privacy), type Y and hit Enter if it asks you for confirmation
  4. When that task is done, or if it failed because it wasn't installed in the first place, type, sudo apt-get install compiz and hit enter/return. Follow the same steps as you did to remove it.
  5. Then reboot your machine, hope this helps!
share|improve this answer
    
still no luck w –  sarveshlad Feb 1 '12 at 15:06
    
have you played with compiz-config-setting-manager before system crash? Enabled login plugin in compiz? –  Tachyons Feb 12 '12 at 2:30
    
nopes never never mind i fixed the issue .... something to do with unity –  sarveshlad Feb 13 '12 at 23:07

Try reinstalling Metacity, by opening a terminal and typing this:

sudo apt-get remove metacity (type password) hit y and enter if it asks

To install:

sudo apt-get install metacity (type password) hit y and enter if it asks

Also try reinstalling Unity itself, package name is "unity", I believe.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.