Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I saw on a couple sites that there were instructions for installing Google Earth 6.2, so I did it. The results were not good. Now, every place I view is broken into rectangles of somewhat different colors, making it very difficult to use.

enter image description here

It does this whether I zoom in or out, and no matter where on the planet I look.

If I could completely remove Google Earth and reinstall it, I could give it another try, but I don't know how to get it completely off my system. I even went into my home directory and found the .googleearth folder and deleted it and then tried reinstalling, but it's always the same story.

Has anyone seen something like this before, and/or have a way to fix it? Thanks!

UPDATE

I tried the instructions on WebUpd8, which basicaly were just that there was an update. I downloaded the 64-bit deb from the Google Earth site, and double-clicked it. It opened the Software Center and said it would conflict, so I figured I should uninstall the previous version. When I then tried to install the new version, it seemed to go well, until I opened it and saw how it looked. So I thought perhaps I had not completely removed the prior version.

I tried running sudo apt-get purge google-earth* googleearth* and then removing everything from /opt/google/earth/free, hoping to clear out any remnants that could interfere with a fresh install, but those haven't worked.

I then followed some older instructions from WebUpd8 for installing Google Earth 6.1 by building a an installable deb with Google-Earth-Package. I now have that older Google Earth working, but 6.2 is still on the computer, too, and is still looking really bad.

UPDATE 2

Output from recommended commands:

    ~$ sudo dpkg --list | grep earth
[sudo] password for mdk: 
ii  google-earth-stable                    6.2.0.5905-r0                           Explore, search and discover the planet
ii  googleearth                            6.0.3.2197+0.6.0-1                      Google Earth, a 3D map/planet viewer
ii  googleearth-package                    0.6.1                                   utility to automatically build a Debian package of Google Earth

Of course, that's after trying to get things working by reinstalling 6.0.3. It shows they're both still there.

~$ sudo apt-get install --reinstall google-earth
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package google-earth
share|improve this question
    
What instructions did you follow and what makes you think removing it and re-installing it is going to make any difference ? Have you considered filing a bug with Google ? –  bodhi.zazen Feb 1 '12 at 0:55
    
Have you tried sudo apt-get reinstall google-earth? –  William Feb 1 '12 at 1:09
    
I tried "sudo apt-get reinstall google-earth" when I read your comment, but it didn't work; it just gave me the error "Invalid operation reinstall". –  Kelley Feb 1 '12 at 20:13
    
I will file it as bug with Google, now that it appears it wasn't some little thing I did wrong. –  Kelley Feb 1 '12 at 23:17

1 Answer 1

come now... that's one you could've found yourself ;)

sudo apt-get install --reinstall google-earth

try as well

sudo dpkg --list | grep earth
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.