Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have pretty poor frame rate when playing .avi video files.

I tried VLC player, but I am still not satisfied because it is bad comparing to windows. I played some .rmvb (RealMedia) movie yesterday, and it was damn slow.

I use ATI/AMD proprietary FGLRX graphic driver and default VLC setup.

enter image description here

Is there anything I can do to speed it up?

share|improve this question
    
From my expirience, amd + linux = no go. –  Dr_Bunsen Mar 25 '13 at 15:52
    
What's the system's overall load and performance?<br> Can you open the system monitor and see?<br> Sometimes Compiz eats all the CPU... <br><br> But if the CPU is fine I recommend X11 as the video output and disabling any hardware acceleration. You could also try SMplayer which has more video outputs available... –  user143307 Mar 25 '13 at 16:23
add comment

3 Answers

Have you tried changing the video renderer in VLC? Also, i think there is a enable hardware decoding checkbox. Also, (at least when using mesa drivers from the optimized ppa) there might be a package that will allow nVidia VDPAU to work with ati cards. One more thing, if your really desperate, buy a Broadcom crystal hd.

share|improve this answer
    
Thanks. Change video renderer to what? –  umpirsky Feb 1 '12 at 7:22
    
Um, honestly, I have no idea. I haven't used VLC in a while, but there are only like 7 options, right? Trial and error, I guess? –  Gothic_Day Feb 3 '12 at 7:49
    
There are i.imgur.com/2Mcg2.png I don't see any difference, do I need to restart player between switches? –  umpirsky Feb 3 '12 at 18:11
    
Based on my somewhat limited experience with graphic drivers, I say use GLX. And a player restart dosent hurt. –  Gothic_Day Feb 5 '12 at 1:37
add comment

Also, have you compared the perfomance differences with using the free drivers and the ATI ones? When you use the free drivers, make sure you have "libgl1-mesa-dri", "libosmesa6", and "libgl1-mesa-dri-experimental" packages installed. For better results, add the ppa "ppa:oibaf/graphics-drivers", "ppa:ubuntu-x-swat/x-updates", and install the "libg3dvl-mesa" package. Your card seems similar to mine at least in terms of age. I have a ATI Radeon Xpress 1150 (RS480M), and these free drivers work for me.

share|improve this answer
    
Thanks. Installed them all, but still same results. Note: when I open "additional drivers" still same list i.imgur.com/fNVRS.png Should I activate them somehow? –  umpirsky Feb 6 '12 at 20:54
    
Well, that's as much as I can be of help. Sorry. On a side note, post release updates are safe and recommended to use instead. –  Gothic_Day Feb 7 '12 at 6:33
add comment

VLC is quite problematic on some formats. What gives me very good results playing .avi files is Smplayer. You can install it from the Ubuntu Software Center or from Synaptic (it depends on your preferences).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.