Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Question:

I can start LumiSoft mailserver in console mode like this:

./lsMailServer.exe -daemon

Unfortunately this blocks the terminal that was used. And I am logged in via ssh.

I'm just experimenting with the server, so I need to restart a lot after configuration changes.

Normally, I'd use the open command in this circumstance, which normally works fine.

It also works fine, when I do open ./lsMailServer.exe with X-Forwarding.

But I want to run the server terminal-only, which requires the -daemon option. Now when I do

open opt/MyPath/lsMailServer.exe -daemon

I get the following error message:

open: invalid option -- 'd' Usage: openvt [-c vtnumber] [-f] [-l] [-u] [-s] [-v] [-w] -- command_line

How can I use open with a program + arguments for that program ?

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

Aaaaah,forget it, one only needs to add -- after open:

openvt -- ls -l

or

open -- /opt/LumiSoft/Debug/lsMailServer.exe -daemon

respectively

share|improve this answer
2  
I was writing an answer just with this information. Anyway, you definitely must give a look and a try to GNU screen. –  enzotib Jan 31 '12 at 19:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.