Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I been having some problems with my graphic card for a time now. But I had enough when I didn't get Oil Rush to work on my HP Pavilion g6. The system has suggested hardware drivers for me, but the first time I installed them they pretty much ruined the graphics. After some time I managed to get the computers to work properly (I thought) again. When the game didn't work I tried to the hardware drivers for the graphic card anyway. First of all there was to possible choices instead of one, as the last time I installed the drivers (when it didn't work out so good). The choices are:

  1. ATI/AMDs proprietary video drivers FGLRX (update for edition)

  2. Proprietary FGLRX-video drivers for ATI/AMD

I realized the drivers probably are pretty much the same, so I tried the first one. But this didn't work. Instead I was asked to "Look in to /usr/var/log/jockey.log". This didn't helped me much. Instead I chose the other one, which was installed and after reboot there where some changes. First of all there was a lot more details for Unity that wasn't there before and some shortcut keys are now working that didn't before (like Ctrl + T and the Prt Sc-button). But overall everything doesn't work as it used to. Like when you browse between the work-spaces it doesn't look the same. To get to the point: it doesn't work well right now even if I got some things better and now will not Oil Rush (as I mentioned in the beginning) even start.

Can someone give me any advice with this? I'm stuck. Can't manage to see whats wrong right now.

My graphic card is AMD Radeon HD 6470M.

share|improve this question
    
This question appears to be abandoned. Unaccepted answer or unanswered, could you perhaps add more detail to your question? If this question no longer applies then you can either delete it or answer it yourself if you've solved the problem. Flagged for deletion. Thanks! –  Ringtail Dec 31 '12 at 15:18
    
Possible duplicate? This thread might help you. Even i have faced same problem but i have followed the below steps which has neatly explained askubuntu.com/questions/205112/… –  Vijay Sali Feb 8 '13 at 15:59
    
AMD and linux is a no-go in my expirience. –  Dr_Bunsen Jun 24 '13 at 17:17

2 Answers 2

I've also faced this kind of problem, I've uninstalled amd drivers removing all fglrx related in synaptic package manager and installed the brand new amd driver released on january 25th 2012 and everything works perfectly now, you should try:

http://support.amd.com/fr/gpudownload/linux/Pages/radeon_linux.aspx

regards

share|improve this answer
    
I'm not getting the file to work actually. It just stops in a working process opening Gedit. –  Lucas Jan 31 '12 at 19:54
    
No, it's just me who is impatient. Will return with an answer about the effect of this solution on my laptop. –  Lucas Jan 31 '12 at 20:11
    
Yeah, finally got the point where it was done. But it did'nt work. I got an error saying that the file could'nt be open because there were unknown symbols in the file. Do you have any suggestions? –  Lucas Jan 31 '12 at 23:40

Also this thread is very helpful: http://ubuntuforums.org/showthread.php?t=1930450

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.