Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

NOTICE: I am completely allowed to do this. This is not meant for accessing sites I am not supposed to go on I know that most threads with "Proxy" in the title have to do with getting to sites they're not supposed to go on.

I hope that I can get this to be as easy as possible. I hope it can be as easy as setting up an OpenSSH server.

What happened My dad has just screwed something up in our router settings, and I can't access Google anymore because if it. I need to be able to access Google. He doesn't like me in the router because he thinks I will make it worse. (I am sick of Bing and Yahoo)

So I want to set up a proxy server that will allow me to work around what he screwed up.

What I want to do I want to host it on a computer in my grandpa's house, and access it with my computer at my dad's house. It's running Xubuntu. I want it to work with the Mozilla Firefox on my computer at my dad's house running Ubuntu 11.10.

How can I set this up?

This is only temporary until he fixes whatever he did.

share|improve this question
    
Did you take a look at this question - How can a proxy be set for the whole Xubuntu system? –  nitstorm Jan 31 '12 at 17:48
    
That is too complex. I need a tutorial from the beginning. –  Dolphin Jan 31 '12 at 17:49
    
I hope that I can get this to be as easy as possible (Like how easy it is to get openssh going) –  Dolphin Jan 31 '12 at 17:54
add comment

2 Answers 2

Install squid. The basic setup (which is provided) will work. Or use the ubuntu doc Squid

share|improve this answer
add comment

If a SOCKS proxy is sufficient for you, you can set it up with one command. Assuming proxy.grandpa.lan is your proxy host, with ssh server installed on it and your account there is Dolphin:

ssh -D localhost:8899 Dolphin@proxy.grandpa.lan

And then set up in your browser, for example in the Firefox 13 I happen to have running right now, Edit > Preferences > Advanced > Network > Settings... > Manual proxy configuration and in the SOCKS Host field put in localhost and Port as per the command line 8899. Most port numbers above 1024 will work. Default seems to be SOCKS v5, which worked at least for me.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.