Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use Ubuntu 11.10. After successful obtain of all available updates I have a problem with authorization of any action that requires my password. I cannot use Ubuntu Software Center, Terminal... My password input is correct because I use it to log in to the system. Can anyone tell me what went wrong?

share|improve this question
    
Does you password contain non-ascii characters? –  enzotib Jan 31 '12 at 17:04
    
Do you realise that (because of security) your password does not appear in the Terminal? Just type your password and hit enter... If you are having problems with Software Center, have you tried a different Package Manager e.g. Synaptic? You could also try a blunderbuss approach by trying these commands in a Terminal, one-by-one: sudo dpkg --configure -a, sudo apt-get -f install, sudo apt-get --fix-missing install, sudo apt-get update, sudo apt-get dist-upgrade, sudo apt-get clean, sudo apt-get autoremove, sudo apt-get update –  arochester Jan 31 '12 at 17:41
    
Yes, I realize that. I tried everything that you mentioned, but I still get error message that my password is incorrect (even after successful login with that same password). –  shecher Feb 1 '12 at 11:49
    
Maybe you are/were using more than one keyboard layout... –  edwin Jul 8 '13 at 3:42
add comment

1 Answer

I had similar problem and I found that I changed hostname in /etc/hostname but not in the rest of places. So check your hostname. If it is not problem with hostname try to remove any asking for password: Complete tutorial for removing password for programs and actions is here: http://linuxibos.blogspot.com/2012/06/run-programs-and-actions-without.html

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.