Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have this file libmodman-2.0.1.tar.gz, and want to install it, so I extracted it, navigated to the directory, then ./ configure and I get this :

~/Downloads/libmodman-2.0.1$ ./configure
bash: ./configure: No such file or directory

This is the content of the libmodman-2.0.1 directory:

/cmake/
/libmodman/
AUTHORS
CMakeLists.txt
COPYING
INSTALL
NEWS

In the file install is this:

cmake ./
make
make test
sudo make install

I tried cmake ./ in the terminal but i get this :

bash: ./cmake: Is a directory

How can I install this file?

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

You should be trying to run cmake in ~/Downloads/libmodman-2.0.1/

Then once you have done that as the INSTALL file says, run make, make test and then sudo make install.

So that is:

cd ~/Downloads/libmodman-2.0.1/
cmake ./
make
make test
sudo make install
share|improve this answer
    
I thought I was doing that, i thought I was running cmake ./ in ~/Downloads/libmodman-2.0.1/ the first time, but obviously not, cause today it worked as you said. Thank you very much ! –  Mihail-Cosmin Munteanu Feb 2 '12 at 7:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.