Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

First off, I realize that what I'm hoping to get is not the expected behavior.

On my older desktop, I have the following set up: Ubuntu 10.04. Xfce running (installed after the fact). I use the Xfce4-terminal, with transparency turned on. In this set up, as expected when a terminal window is over the desktop, it shows the desktop background image. However, if I drag the terminal window on top of a window, it continues to show the background as if the window wasn't there. Transparency Weirdness

It's kind of weird that way, but I've gotten used to it.

Now, as I've set up my new desktop (11.10 w/ Xfce installed) transparency works the 'normal/correct' way, but I'd rather have it go back to leaving out windows.

So is it possible to get my new setup to do the old way?

share|improve this question
    
This is called pseudo-transparency and was how things worked for all "transparent" terminals in the past. What is used might also depend on the graphics driver capabilities... –  JanC Jan 31 '12 at 20:00
    
In Xfce, you can go to settings manager > window manager tweaks and switch off the compositor. That should give you back pseudo-transparency, as long as you are not running any other compositors and only the standard Xfce window manager. You will also have to restart guake to see any difference. This is about the only way to do it I think. –  user76204 Mar 18 '13 at 17:59
    
@Mik Bang! That did it. Go ahead and put that comment into an answer, and I'll accept it! (It's been long enough that I'm pretty used to this way by now, so I'm not sure if I'll actually use it, but I'm very thankful to know!) –  David Oneill Mar 21 '13 at 13:24

1 Answer 1

up vote 1 down vote accepted

(In response to David's comment I offer this answer as a possible solution, as it worked for David and me with recent versions of Xfce.)

In Xfce, you can go to settings > settings manager > window manager tweaks and switch off the compositor, which manages transparency and the overlaying of X windows. You can do it via the command-line with xfconf-query:

xfconf-query -c xfwm4 -p /general/use_compositing -s false

That should give you back pseudo-transparency, as long as you are not running any other compositors and only the standard Xfce window manager. With compositing on I had full 'real' transparency with guake and with it off I had the old style 'pseudo' transparency.

You will also have to restart guake to see any difference. This is about the only way to do it I think, as there won't be any settings in guake itself as it is highly dependent on your own customised setup and whether you have compositing enabled in xfwm4 or in whichever window manager you are using on your setup.

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.