Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a problem similar to what's been mentioned in a few other questions, namely:

I have read a number of other posts here and on other forums and have tried a bunch of different solutions.


The Problem

The problem manifests itself only in Gnome3. I have tried KDE, Unity and KFCE and all are fine. The graphics corruption is visible only on gnome panels (see images below).

Everything works fine with the free ATI drivers, but they just lack power. The problem occurs with the proprietary ones from AMD/ATI. I have installed version 11.11 and 12.1 as per the instructions on wiki.cchtml.com/index.php/Ubuntu_Oneiric_Installation_Guide. I have the same exact problem in both cases. I have tried this on clean installs of Ubuntu 11.10 Oneiric Ocelot (x64 and x86) and on Linux Mint 12 (x64) with the same results.

Also, it looks like after some time of not using it, the PC just freezes. Maybe an overheat? Will look into it.


Things I've Tried

I have tried the following fixes:

  • Different versions of drivers from ATI including the latest - this worked for some, not for me.
  • Installing Oneiric specific package generated from driver, as well as the default install
  • Removed the Unity Global menu
  • Disabled file manager handling desktop
  • Disabled Compiz "detect refresh rate"
  • Sync to VBlank in Compiz on and off


Please help! This is the first time in 10 years that I've finally had the chance to switch my primary desktop to Linux (stopped doing .NET dev work), and this is really getting me down.


This is what the problem looks like:

Problem screenshot 1

And: Problem screenshot 2

share|improve this question
    
This should be fixed if you use 12-1. askubuntu.com/a/74172/6005 –  jrg Jan 31 '12 at 15:46
1  
Although I have already tried 12.1, shockingly something about this actually worked. The procedure on the face of it is identical to the one I used, and the file name for the driver is the same (although I d/led mine directly from the site). At this stage I don't know why this worked and all the previous attempts didn't. I'm going to try to replicate the result, and get back to you. Thanx. –  AndyAtTheWebists Jan 31 '12 at 16:38
    
Good stuff! Let me know how it goes. –  jrg Jan 31 '12 at 16:42
    
You should try this: [look at this post][1] [1]: askubuntu.com/questions/100255/… regards, Thierry –  thierry Jan 31 '12 at 18:34
    
So yeah, it does work now, but I've checked against the notes for my original procedure and other than additionally installing linux-headers-generic (as suggested in the amd wiki) it's exactly the same. I can only gather that there was a problem with the original driver file I downloaded, as this time I re-downloaded from the URL in jrg's link. Very frustrating, but there it is. –  AndyAtTheWebists Jan 31 '12 at 18:54

2 Answers 2

Ok, so the comments by jrg and Thierry resolved the issue, which basically (presumably) was a bad driver download (maybe I downloaded the wrong version but saved it with the name of the newer one... I dunno, I've already deleted that file so I can't check).

Anyway, I've spent a fair bit of time getting to the root of the problem, and wanted to summarize my knowledge for the sake of posterity (and anyone else who might stumble upon this question with similar problems).

All in all, the current 12.1 drivers from AMD seem to resolve all my problems on Oneiric.


Installing proprietary ATI/AMD Radeon driver

See this question for a step by step guide to installing them.

To cross reference, troubleshoot, and get updated info you can have a look at the AMD Wiki here.

Troubleshooting further problems

I have come across the following suggestions pertaining to various ATI graphics issues with Oneiric:

  • Remove the Unity Global menu sudo apt-get remove appmenu-gtk3 appmenu-gtk appmenu-qt (Beware as this will break your Unity shell)
  • Disabled "file manager handling desktop" (in desktop tab) using the Gnome Advanced Settings package $ sudo apt-get install gnome-tweak-tool
  • Disable "detect refresh rate" in Compiz (found in General --> Composite) $sudo apt-get install compizconfig-settings-manager
  • Turn off 'Sync to VBlank' in Compiz (found in General --> OpenGL)

Going back to open source drivers

Good instructions here.

Other things

Here's one about enabling hardware acceleration that I have not tested yet.

If you're having trouble with Catalyst Center accepting changes relating to a dual-monitor setup, first in 'Displays' disable mirroring and then disable one the monitors, restart, enable second monitor in Catalyst, restart. This did it for me after a bit of trial and error.

share|improve this answer

I found that using the post-release drivers (in the Additional Driver tool) fixes the problem for me. I was having the same (or at least similar looking) issue with a Radeon HD 3450 on 11.10. The gnome-tweak-tool temporarily fixed the fonts, but not the colors and icons.

I removed the regular fglrx packages and installed the post release version, and now it works fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.